PDA

Vollständige Version anzeigen : Tabelle im FE/BE öffnen dauert 5min (5min) Minuten!


Gast
16.01.2003, 13:31
Hallo Forum
(was tät ich ohne Dich?)

A2000, Win2k:

Unser FE ist 70MB gross (enthält nur Reps und Frms + ca 100 gelinkte Tabs aus ca. 4 versch. BE)
BE z.T. 1.3GB (reine Tabellen)

Von DI auf MI dauert auf einmal das öffnen einer Tabelle 5min!
(öffnen = Doppelklick im Datenbankfenster)

Die FE/BE wurden komprimiert, aber das hat nix gebracht, zudem waren FE/BE auch schon viel grösser!

Jetzt kommt aber der Hammer:
Mache ich 'Select * from irgendeinerTab' machts flutsch und die Abfrage wird ausgeführt! und ich habe die Daten der Tabelle!

Wo ist der Unterschied wenn ich Select * mach oder eben die Tab direkt öffne?

Habe PC total neu aufgesetzt! Dann liefs für bis heute Mittag... und jetzt wieder nicht mehr!

Ideen?

KHS
16.01.2003, 14:22
Hast du die DB auch schon mal repariert?

Performance-Probleme wurden übrigens z.B. <a href="http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=79560" target="_blank">Aufteilung Front-/Backend ./.. Performance</a> auch schon mal diskutiert.

Ggf. auch <a href="http://www.donkarl.com/FAQ/FAQ1Grundlagen.htm#1.22" target="_blank">FAQ 1.22</a> oder <a href="http://www.donkarl.com/FAQ/FAQ1Grundlagen.htm#1.23" target="_blank">FAQ 1.23</a>

Ob dir das allerdings hilft, kann ich nicht sagen.

StehtimSchilf
16.01.2003, 16:20
Danke.... aber schon gelesen und hat nix gebracht :(

Sascha Trowitzsch
16.01.2003, 16:39
Ich finde jetzt die Seite bei MS nicht (es ging um Optimierung und Abfragen), wo zu lesen war, dass Abfragen, die ein SELECT ... IN 'Pfad' machen, grundsätzlich performanter seine, als Abfragen auf verknüpfte Tabellen. Es war allerdings keine Begründung dafür angegeben gewesen. Ich gehe davon aus, dass bei Abfragen einiger Verwaltungs-Overhead fehlt (Tabelleneigenschaften lesen, Attribute, etc.) und auf die Daten "direkter" zugegriffen wird.

Ich denke, bei diesen gigantischen Datenmengen ist aber ohnehin nicht mehr viel drin.
Man spricht bei Access von handhabbarem Backend von 1 GB. Alles drüber verursacht Probleme.

Ciao, Sascha

Nouba
17.01.2003, 06:39
Hallo,

Microsoft® Access Performance Tips (http://support.microsoft.com/default.aspx?scid=/support/Access/Content/PerformanceTips.asp) und Making Access Faster - 168 Tips to Speed Up Your Apps! (http://www.fmsinc.com/tpapers/faster/) scheinen gute Lektüre zu sein..

WIKING Peter
17.01.2003, 07:15
Hallo,
noch ein kleiner Tipp: Den Fehler nicht nur in Access suchen, sondern auch allgemein im Netz. Ich hatte auch ein Problem mit einer FE am Rechner und einer BE auf dem Server. Es lag hierbei am Virenscanner, der jedes Datenpaket ins Netz auf Viren gescannt hatte. Eine Umstellung der Virensuche brachte eine erhebliche Geschwindigkeitsverbesserung. Man sollte den Netzwerkadministrator fragen, ob der Server automatisch ein Antivirentool auf einen Client installiert. Dies kann so eingestellt werden, wenn ein neuer Rechner (Zitat ... Habe PC total neu aufgesetzt!) sich im Netz anmeldet. Daher auch das Laufen ohne Probleme bis Mittags und danach nicht mehr.
Gruß
Peter

StehtimSchilf
17.01.2003, 15:48
Ich danke für die Antworten!

Ich hab mal die Links von Noube unter die Lupe genommen und bemerkt, dass unsere DB gegen all 168 Tipps verstöst ;)

Aber ich werd mir das mal übers WE zu Gemüte führen!

Danke!

StehtimSchilf
27.01.2003, 10:11
Das Problem hängt mit diesem Beitrag (http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=84701) zusammen!

Das öffnen dauerte 5min, weil in dieser Zeit zw. 1-3GB Daten heruntergeladen wurden!

Wenn ihr also auch mal lange Wartezeiten habt, so schaut euch doch mal den Netzverkehr im FE an!

Diese Phänomen tauchte auf, weil wir ein FE mit einer DB verknüpften, die als BE diente - aber zugleich wurde auf dieser DB direkt gearbeitet!

Aber eben, siehe diesem Beitrag (http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=84701)

Gruss
SiS