PDA

Vollständige Version anzeigen : Office öffnet keine Dateien mit Leerzeichen


MisterDT
14.12.2000, 08:24
Habe das Problem, dass Office 97 keine Dateien mit Leerzeichen öffnet. Der Spaß fing unter Win 2000 an. Dateien wie 'lies mich.doc' wurden nur mit der Fehlermeldung, dass die Datei 'lies' und später die Datei 'mich.doc' nicht geöffnet werden können. Aber geöffnet wird sie letztlich!

Wenn ich diese Datei mit dem Editor öffne - kein Problem.

Öffnen heißt hier jetzt per Kommandozeile ( Doppelklick auf Symbol). In den Dateitypen-Eigenscahften steht beim Öffnen ("%1") - also sollte es eigentlich funktionieren.

Unter NT 4 konnte ich die Dateien erst öffnen - aber nach diversen Tests (dauerhafte Zuordnung der Endung XLS dem Editor, dieser konnte die Dateien mit Leerzeichen problemlos öffnen, und anschließend wieder Zuordnung der Endung XLS zu Excel) kann nun Excel auch auf diesem Rechner die Dateien nicht ohne Fehlermeldung öffnen!

Hat jemand einen Tip - es ist echt nervig! (vor allem wenn in den Word-Serienbrief- Dokumenten Verknüpfungen zu Excel-Tabellen (diese mit Leerzeichen) existieren)

MisterDT
14.12.2000, 09:19
Habe gerade festgestellt, dass das Problem nur auftritt, wenn das Office-Programm noch nicht geöffnet ist! (d.h. wenn Word oder Excel erst noch gestartet werden müssen).
Falls diese Programme schon laufen, dann gibt es dieses Problem nicht!
Versteh das einer! :-(

Gast
16.03.2004, 17:48
Ohne auf weitere Funktionalitätprobleme einzugehen: Excel ließ sich bei mir über Abschaltung von DDE überlisten... Weiß allerdings nicht, ob sich das bei Dir auch anbietet...

KlausF
16.03.2004, 18:23
hi gast,

habe mal bei mir nachgeschaut (windows xp, diverse Word-Versionen):

Es gibt eine eigene Option DDE-Anwendung nicht aktiv, die normalerweise leer ist. In diesem Fall benutzt Windows den gleichen Befehl wie unter DDE-Nachrich.

In der Registry ist die Option im Schlüssel HKEY_CLASSES_ROOT\Word.Document.8\shell\open\ddeexec\IfExec

Du kannst ja mal nachsehen, ob du den schlüssel hast und was da drin steht.

ciao
Klaus