PDA

Vollständige Version anzeigen : Datumsberechnungen vor 1.1.1900


Moritz
28.07.2001, 15:27
Excel kann Datumsberechnungen zwischen 01.01.1900 und 31.12.9999 ausführen. Kann mir jemand erklären, wie ich Berechnungen auch mache, deren Datum vor dem 01.01.1900 liegt?

Beispiel: Die Differenz 31.12.2001 - 31.12.1800 in Jahren

MarioR
28.07.2001, 15:43
Hallo Moritz,

so kannst Du das z.B. lösen.
Zelle A1 und A2 als Text formatieren. In A1 kommt der 31.12.2001, in Zelle A2 der 31.12.1800 rein. In Zelle A3 wird das Ergebnis mit folgender Formel ausgerechnet:
=WERT(RECHTS(A1;4))-WERT(RECHTS(A2;4))

Da die Zellen als Text formatiert sind, musst Du das eingegebene Datum selbst überprüfen. Du könntest dazu z.B. die Daten erstmal in B1 und B2 eingeben und nur nach A1 und A2 kopieren, wenn die Daten stimmen.

Mario

Moritz
28.07.2001, 15:57
Besten Dank Mario. Das funktioniert.
Kannst Du mir jetzt auch noch die Differenz in Tage bzw. Monate errechnen?

Moritz

MarioR
28.07.2001, 18:38
Du willst ja ganz knifflige Sachen gelöst haben ;)

Tagesformel in C3:
=WENN(LINKS(A1;2)>=LINKS(A2;2);WERT(LINKS(A1;2))-WERT(LINKS(A2;2));WERT(LINKS(A1;2))+WAHL(REST(WERT(TEIL(A2;4;2))+B3;12);31;28;31 ;30;31;30;31;31;30;31;30;31)-WERT(LINKS(A2;2)))

Monatsformel in B3:
=WENN(TEIL(A1;4;2)>=TEIL(A2;4;2);WERT(TEIL(A1;4;2))-WERT(TEIL(A2;4;2));WERT(TEIL(A1;4;2))+12-WERT(TEIL(A2;4;2)))-WENN(LINKS(A1;2)>=LINKS(A2;2);0;1)

Jahresformel in A3:
=WERT(RECHTS(A1;4))-WERT(RECHTS(A2;4))-WENN(TEIL(A1;4;2)>TEIL(A2;4;2);0;WENN(B3=0;0;1))

Allerdings übernehm ich für die Formeln keine Garantie.
Das Ergebnis ist in dieser Reihenfolge gedacht:
Startdatum + Jahre + Monate + Tage = Zieldatum
In Schaltjahren kannst Du einen Fehler von 1 Tag bekommen.

<font size="1" face="Century Gothic">Moderatorenanmerkung: die Überarbeitung dieses Beitrages ist im Zuge der Arbeiten zu sehen, die durch den Wechsel der Forensoftware zum 01.01.2003 verursacht wurden.

Es wurden in diesem Beitrag Links korrigiert, die auf falsche Adressen zeigten und die Signatur angepasst...</font>