PDA

Vollständige Version anzeigen : Addieren von Stunden macht probleme


Kneti
13.07.2001, 13:03
Hallochen !

Ich habe mich immer in Sicherheit gewiegelt, doch nun habe ich beim Umbau einen Fehler festgestellt - den ich nicht geändert bekomme.

Ich habe in einer Spalte immer die Arbeitszeit untereinander für jeden Tag eine.
6:00
8:40
7:50
usw. diese sind im Format hh:mm und sind Ergebnisse aus einer anderen Formel

in einer anderen Spalte sollen die Zeiten fortlaufend zusammengerechnet werden so das sie immer den aktuellen Stand anzeigen.
6:00
14:40
22:30

das funktioniert bis hierhin !
Doch wenn jetzt die nächste Zeit dazugerechnet wird, kommt darin die Wendestelle 24:00 und es fängt einfach wieder von vorn an zuzählen.

Sprich ich habe trotz =Summe(K3:K33)
nur 12 Stunden obwohl 30 Tage zusammengezogen werden.
Und auch wenn ich die Zeiten fortlaufend summiere passiert der Wechsel bei 24:00...
Wie kann ich es verhindern das er bei 24:00 wieder von vorne zählt ?

Ich habe bei einer anderen Spalte nun eine riesige Formel drin - die scheint das Problem automatisch zu beheben, doch die kann ich nicht anwenden da es etwas anderes ausrechnet. Ich habe dort auch das Format
[hh]:mm statt hh:mm drin. Das habe ich dann ausprobiert - dann bekomme ich aber 529:00 raus und bei der Summe dann 17623:00 oder so.
ich muss aber um die 160 h rausbekommen...
Auch habe ich gedacht es könne an der Formel liegen die in dem Feld mit drin steht bei den Uhrzeíten und machte eine neue Spalte wo nur =F3 drin steht =erfolglos !

Wie kann man das Problem lösen ?

Wäre Euch sehr dankbar wenn ihr mir helfen würdet.
Gruß René

jinx
13.07.2001, 13:55
<font size="2" face="Century Gothic">Moin, René,

hat der Tag bei Dir mehr als 24 Stunden?

Formatiere das Anzeigefeld auf Datum und Uhrzeit, dann wird Dir im Datum die Anzahl der vollen Tage mit 24 Stunden und dahinter der Anteil der Stunden angezeigt.

<font color="#808080" size="3" face="Arial Black">cu
jinx</font>

<font size="1" face="Century Gothic">Moderatorenanmerkung: die Überarbeitung dieses Beitrages ist im Zuge der Arbeiten zu sehen, die durch den Wechsel der Forensoftware zum 01.01.2003 verursacht wurden.

Es wurde in diesem Beitrag die Signatur angepasst...</font>

MarioR
13.07.2001, 13:57
Hallo René,

Du wälzt ja riesige Probleme.

Der Umsprung bei 24:00 kommt daher, dass Excel dann in Tagen weiterzählt. Gib mal probehalber tt:hh:mm als Format ein, dann ist das zu sehen.

Das richtige Ergebnis erhälst Du, wenn Du als Formel das verwendest:
=24*Summe(K2:K33)
Formatierung Standard (oder Zahl)

Mario

Kneti
13.07.2001, 14:01
Hallo Jinx,

guter Vorschlag, aber leider für mich nicht zu gebrauchen.

Ich will keine Tage angezeigt haben, sondern sehen wieviele Stunden im Monat bzw. im Jahr gearbeitet wurden.
Und ob das soll von 160 h unter oder überboten wurden...
ich brauche also eine reine Anzeige von Stunden !

Gruß René

Kneti
13.07.2001, 14:10
Hallo Mario,

ja ich wälze hier Problem auf, und dabei wollte ich das gute Formelwerk von Euch jetzt voll nutzen...
Doch da habe ich beim Eintragen das ja nun teilweise automatisiert ist festgestellt das die Stunden sich nicht richtig zusammen zählen.

00:00 hier sind 0
07:49 hier sind 7:49
08:36 hier sind 16:25 erreicht...
08:56
08:46
06:33
00:00
00:00
06:38
08:53
07:35
08:27
08:20
08:23
08:09
00:00
00:00
08:37
07:48
07:50
05:46
05:48
06:29
00:00
00:00
00:00
00:00
00:00
00:00
00:00
00:00
19:23 ???? bischen wenig Oder?
Bei dir kamen zwei Stunden mehr raus !
War also auch nicht so richtig.
Gruß René

MarioR
13.07.2001, 19:22
Hallo René,

also es tut mir leid, aber wenn ich Dein Beispiel nachvollziehe erhalte ich als Ergebnis 139,383333 und das dürfte ja stimmen.

Mario


PS
Wenn ich mir das Ergebnis so anschaue, ist es vielleicht besser, wenn Du Deine ursprüngliche Formel beibehältst. Änder lieber die Formatierung der Summenzelle auf [h]:mm.

[Dieser Beitrag wurde von MarioR am 13.07.2001 editiert.]

Kneti
14.07.2001, 18:17
@mario

Leider kann ich meine ursprüngliche Formel nicht beibehalten, denn dieses Blatt errechnet jetzt endlich vieles automatisch aus. Ich habe natürlich das Format [hh]:mm verwendet. Ich habe auf einem seperaten Blatt mal MANUELL 4x 8:00 Std. untereinander geschrieben. Daneben habe ich die Stunden nacheinander Summieren lassen per Formel:
=summe(b3:b4) darunter dann =summe(b3:b5) und so weiter so wird immer der nächste Arbeitstag zugerechnet. Auch über 24h zeigt es dann an also kein neuer Zählbeginn.
Auf einem anderen Blatt funktioniert es - eben nur in meinem Blatt wo die Werte mittels Formel errechnet werden nicht.
Ich habe auch schon versucht, mittels =j3 den Wert 8:00 in eine andere Spalte zu legen, da dort dann keine Formel ist und es dort zu summieren - aber auch das klappte nicht.

Weiß der Hugo warum...

Wo ist nur Hugo ?
Gruß René

tornado
18.07.2001, 07:26
Hallo Kneti

Hat sich inzwischen Dein Prob mit der Stunden-Summe erledigt?

Wenn nicht, ist folgende Einstellung wichtig:
Zellenformat für Summe = [h]:mm (NUR 1xh !!)

Jedenfalls funzt bei mir das so.

Gruss
Roger

Kneti
18.07.2001, 08:40
Ja mein Problem mit den Stunden addieren hat sich erledigt !

Jetzt kann ich ohne weiteres 32 Stunden addieren, es lag nicht an der Formatierung auch [hh]:00 geht, es lag an der Formel !
ich hatte 24-D3 in einer Klammer geschrieben und kam weil 24*24 =576 ist statt 24H musste dort ne 1 rein für 1 Tag das funktioniert jetzt.
Vielen DANK !!!
Gruß René

jinx
19.07.2001, 21:11
<font size="2" face="Century Gothic">Moin, Kneti,

ich hätte vor meinem ersten Beitrag nur die Augen aufmachen brauchen: Sowohl 97 als auch 2000 bieten unter Format - Zellen - Uhrzeit die folgende Option:
37:30:55.

Tja, und da hast Du Deine Stunden an der Perlenkette.... (auch die lange Reihe wird zu 139:23:00).

Nur für die Zukunft ;)
<font color="#808080" size="3" face="Arial Black">jinx</font>

<font size="1" face="Century Gothic">Moderatorenanmerkung: die Überarbeitung dieses Beitrages ist im Zuge der Arbeiten zu sehen, die durch den Wechsel der Forensoftware zum 01.01.2003 verursacht wurden.

Es wurden in diesem Beitrag Links korrigiert, die auf falsche Adressen zeigten und die Signatur angepasst...</font>