PDA

Vollständige Version anzeigen : Laufzeitfehler '1004'


ulanghorst
22.05.2001, 15:53
Ich habe mit Excel 97 das Problem, dass beim Neustarten einer Datei mit Arbeitsblättern, deren Zellen teilweise geschützt sind, bei der ersten Dateneingabe die Fehlermeldung "Lauzeitfehler '1004' Dieser Befehl kann in einer geschützten Tabelle nicht verwendet werden ..., bla bla bla!" erscheint.
Diese Meldung scheint allerdings völliger Blödsinn zu sein, weil alle Eintragungen und Zellbezüge trotzdem fehlerfrei funktionieren.
Kann mir jemand weiterhelfen, wie man diese falsche Fehlermeldung umgehen kann, oder hat die Fehlermeldung doch irgendwo seinen Sinn?

Vielen Dank und Grüße,

Uli

jinx
24.06.2001, 19:06
<font size="2" face="Century Gothic">Moin, Uli,

jemand (Neutrum, bitte!) macht sich die Mühe, Teile der Tabelle zu schützen:
a) um Bearbeiter vom Überschreiben z.B. von Formeln oder feststehenden Eingaben abzuhalten;
b) weil er die Funktion einfach mal ausprobieren wollte;
c) weil es die Aufgabenstellung (Schule/Ausbildung/Lehrbuch) erforderte;
d) weil er vor Langeweile nicht wusste, was er tun sollte;
e) damit eine Frage im Forum gestellt werden konnte.

Antwort nur für a):
Normalerweise hebt man diesen Schutz für die Dauer der Bearbeitung auf und setzt sie danach wieder. Dies geschieht über Extras / Schutz / Blattschutz -à aufheben.
Probleme gibt es. Wenn ein Kennwort verlangt wird.
Tja, entweder man ist derjenige, der dieses Kennwort vergeben hat, dann sollte man das Sieb, was man als Gedächtnis hat, durch die Notiz des Wortes an einem sicheren Ort unterstützen (also nicht dem Computer – für den Fall, man hat das Kennwort zum einloggen vergessen).
Oder: Man hat dieses Kennwort nicht vergeben. Dann kennt man hoffentlich denjenigen, der dies geschützt hat. Ansonsten gilt dies hier (http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=83666) !

Warum Du aber in geschützten Zellen Eingaben machen kannst, enthüllt wohl ein Blick in den Code. Da ich diesen nicht kenne, stelle ich auch keine Vermutungen an...

So, und nun die Frage, ob die Meldung einen Sinn hat: siehe Deinen Code und die Antwort a)-

In diesem Sinne
<font color="#808080" size="3" face="Arial Black">jinx</font>

<font size="1" face="Century Gothic">Moderatorenanmerkung: die Überarbeitung dieses Beitrages ist im Zuge der Arbeiten zu sehen, die durch den Wechsel der Forensoftware zum 01.01.2003 verursacht wurden.

Es wurden in diesem Beitrag Links korrigiert, die auf falsche Adressen zeigten und die Signatur angepasst...</font>