PDA

Vollständige Version anzeigen : Ist es möglich eine Eingabe zu verweigern?


Dinoto
30.03.2001, 23:32
Hallo
Ich habe eine Frage zum Excel 2000:
Ist es möglich wenn ich z.B.in A1 die Zahl 5 schreibe und in A3 dasselbe, dass es eine Formel gibt die dann eine Fehlermeldung anzeigt oder alle Zahlen rot schreibt oder dass es verweigert die Zahl zu schreiben?

Manuela Kulpa
31.03.2001, 07:08
Hallo Dinoto!

Das geht recht einfach! Setze einfach eine Gültigkeitsregel für den Bereich ein, den du überprüfen möchtest. Anbei ein kleines Beispiel!

Gehen wir von einer Überprüfung der Zellen A1 bis A10 aus.

1. Klicke die noch leere Zelle A1 an.
2. Klicke in das Menü Daten -> Gültigkeit
3. Auf der ersten Seite Einstellungen solltest du folgendes einstellen:
Zulassen: Benutzerdefiniert
Leere Zellen ignorieren: Ja
Formel: =ZÄHLENWENN($A$1:$A$10;A1)<>2

Kurz zur Erklärung der Formel! Die Formel ergibt True, wenn der Wert nur einmal vorhanden ist. Taucht der Wert ein zweites mal auf, ergibt die Formel False und die Fehlermeldung erscheint. Wichtig ist, dass du den zu überprüfenden Bereich absolut setzt ($A$1:$A$10) und der Wert, der überprüft werden soll (A1) relativ.

4. Klicke auf die Registerkarte Fehlermeldung und stelle deine Meldung ein. Z.B.
Stil: Stopp
Titel: Du Nase
Fehlermeldung: Der Wert darf nicht zweimal eingetragen werden!

So, nun solltest du den leeren Inhalt der Zelle A1 in die Zellen A2 bis A10 kopieren. Wobei hier die Gültigkeitsmeldung auf diese Zellen übertragen wird.

Anschließend kannst du einen kleinen Test starten, und erst mal unterschiedliche Werte eintragen. Es sollte keine Meldung erscheinen. Versuche dann in einer Zelle, einen Wert zu wiederholen und schwupps taucht die Fehlermeldung auf.

Falls du Fragen hast, melde dich!

<font size="2" face="Century Gothic">Moderatorenanmerkung: die Überarbeitung dieses Beitrages ist im Zuge der Arbeiten zu sehen, die durch den Wechsel der Forensoftware zum 01.01.2003 verursacht wurden.

Es wurden in diesem Beitrag Links korrigiert, die auf falsche Adressen zeigten...</font>