PDA

Vollständige Version anzeigen : Generierung der Jahreszahl beim Datenimport


UStolze
04.01.2001, 16:12
Hallo,
ich kämpfe mit folgendem Problem:

Beim Datenimport mit Datenfeldern im Format ttmmjj werden von Excel alle Jahreszahlen kleine 1930 als Jahreszahlen in 2001 interpretiert. Tatsächlich sind dies jedoch Geburtstage aus dem Jahr 19xx.
Kennt jemand eine Möglichkeit, die richtigen Jahreswerte zuzuweisen?

Vielen Dank für Eure Hilfe

------------------


[Dieser Beitrag wurde von UStolze am 04.01.2001 editiert.]

Wolfgang
13.01.2001, 23:02
Versuchs mal mit der Formel
=WENN(JAHR(A1)<1930;DATUM(JAHR(A1)-100;MONAT(A1);TAG(A1));DATUM(JAHR(A1);MONAT(A1);TAG(A1)))
Wenn Datumswerte z.B. in Spalte A stehen. Danach die Spalte mit der Formel kopieren und Bearbeiten Inhalte einfügen Werte anklicken.

UStolze
15.01.2001, 09:59
Original erstellt von Wolfgang:
Versuchs mal mit der Formel
=WENN(JAHR(A1)<1930;DATUM(JAHR(A1)-100;MONAT(A1);TAG(A1));DATUM(JAHR(A1);MONAT(A1);TAG(A1)))
Wenn Datumswerte z.B. in Spalte A stehen. Danach die Spalte mit der Formel kopieren und Bearbeiten Inhalte einfügen Werte anklicken.

Vielen Dank, Wolfgang

hat super geklappt!


<font size="1" face="Century Gothic">Moderatorenanmerkung: die Überarbeitung dieses Beitrages ist im Zuge der Arbeiten zu sehen, die durch den Wechsel der Forensoftware zum 01.01.2003 verursacht wurden.

Es wurden in diesem Beitrag Links korrigiert, die auf falsche Adressen zeigten...</font>