PDA

Vollständige Version anzeigen : Runtime-Version und Win ME


Ikke
02.11.2001, 23:24
Hallo,

ich habe da ein Problem! Ich habe mit dem Setup-Assistenten (ODE 97) eine Laufzeitversion von Access mit einer meiner DB's erstellt. Das habe ich nun auch schon öfter gemacht und hat bislang immer geklappt.
Nun habe ich aber versucht das Programm bei meiner Frau auf dem Rechner zu installieren (Win ME). Läuft auch alles gut, nur kommt ganz am Ende der Installation die Meldung, daß das Setup nicht komplett abgeschlossen werden konnte. Auswirkung ist, das die Einträge im Startmenü nicht vorgenommen wurden. Die Dateien scheinen alle sauber in das Zielverzeichnis entpackt worden zu sein. Auch das Readme-File, welches nach der Installation angezeigt werden kommt nicht.
Hat hier jemand einen Tip, woran das liegen kann? Die Knowledge-Base schweigt sich hierzu leider aus.
Gibt es vielleicht andere, bessere Tools für die Installationsroutine?
Für Hilfe wäre ich wirklich SEHR dankbar!! ;)

Mattes
03.11.2001, 18:59
Hi Ikke,

tja zu Deinem eigentlichen Problem kann ich nichts sagen, aber ME macht NICHTS als Probleme! Installier doch 98.

( Ja, Ja toller TIp, ich weiss :-)) )

Ikke
03.11.2001, 21:34
Danke für die Antwort Mattes.
Aber das Problem ist weniger, daß ich das nicht installieren kann, als vielmehr, daß meine Kunden das nicht werden installieren können. Hast Du schon mal versucht einem Kunden klar zu machen, daß er sich doch lieber ein anderes OS installieren soll?
Welche Installationsroutine verwendest Du denn? Gibt es denn keine Alternative zum Setup-Assistenten der Developers-Edition?

Mattes
04.11.2001, 13:38
Hi Ikke,

war nicht wirklich ernst gemeint, Du sagtest, es handelt sich um den Rechner Deiner Frau, da wäre es halt die einfachste Lösung gewesen.

Firmenrechner mit ME, tja das kenn ich auch.

Alternativen zur DEV sind mir leider auch nicht bekannt!

Viel Glück noch!

Ikke
04.11.2001, 13:55
Naja hätte ja sein können, aber danke für die Antwort Mattes!!!!!!!!!!!

Sascha Trowitzsch
04.11.2001, 15:15
Setups kannst du mit beliebigen entsprechenden Tools machen, also dem Installshield, WiseInstaller uswusw.
Umsonst und brauchbar, wenn auch nicht besonders intuitiv, ist InnoSetup.

Der Vorteil des PDW ist das Scannen der Dependencies in der Datenbank. Das können andere Tools nicht (..soviel ich weiß.)
Wenn du also mit einem anderen Tool ein Setup erstellst, dann würde ich auf jeden Fall mit dem PDW die DB scannen und schauen, welche Dateien er in das Setup einbindet. Diese alle sollten auch wirklich mit ausgeliefert werden und müssen evtl. auch 'installiert', also z.B. DLLs in der Registry registriert werden.

Ich finde im Gegensatz zur landläufigen Meinung übrigens den PDW nicht so schlecht.

Dein Problem scheint ja aber ein anderes zu sein: Das Runtime-Setup.
Dafür gibt es natürlich keinen Setup-Ersatz. Versuche erstmal, die Runtime gesondert zu installieren. Wenn es nicht richtig funktioniert, melde dich nochmal.

Ciao, Sascha

Ikke
04.11.2001, 17:34
Asche über mein Haupt......
In meiner Signatur steht zwar, dass ich keine Rechtschreibfehler mache, aber das bedeutet ja nicht zwangsläufig auch, dass ich lesen kann.... :rolleyes:
Ich wollte, dass nach der Installation automatisch die ReadMe-Datei angezeigt wird, hatte aber übersehen, dass die da nur Ausführbare Dateien zulassen, daher der Fehler. Tja die Routine ist jedermanns Feind.
Auf jedem Fall vielen Dank für die Hilfe. Und die Tips von Sascha werde ich mir mal genauer ansehen!!!!! ;)