PDA

Vollständige Version anzeigen : "Nachschlagen" bei Tabellen


Olli
17.10.2001, 19:26
Kann mir jemand bei folgendem Problem helfen *verzweifel*

Bei einer Tabelle möchte ich mittels eines Nachschlagefeldes ein Wert aus einer anderen Tabelle übernehmen. Die Nachschlageinfo soll aus 4 Spalten bestehen und der Wert den ich übernehmen möchte steht in Spalte 2 !

Im Entwurfsmodus für die Zieltabelle sollte man das im Menü "Nachschlagen" unter der Option "Gebundene Spalten" einstellen können. Aber egal welche Spalten-Nr ich hier eingebe, er übernimmt immer die Werte der ersten Spalte !!

Kurz zum Hintergrund: Ich möchte deshalb unbedingt die zweite Spalte haben, da die erste Namen enthält, die ich durch Eingabe des Anfangsbuchstabens gleich in die Nähe des gesuchten Namen bringen will (ca. 1000 Datensätze). In der 2. Spalte steht dann die benötigte Kundennummer.

Danke schonmal für Eure Tips !!

siboern
17.10.2001, 19:46
Hallo Olli,
verstehe ich das richtig? Soll dieses Nachschlagen bzw. das Übernehmen von Werten aus einer Tabelle in die andere alles auf Tabelleneben stattfinden? Warum nicht mit Abfragen oder sonstwie?
Gruß Siegfried

Olli
17.10.2001, 20:11
habe ich mir noch nicht überlegt, das Nachschlagen mit Abfragen auszuführen - gibt es da wirklich Vorteile ????!

Muß ich nochmal überlegen ! DANKE !

Olli12345
18.10.2001, 11:06
Nö, geht doch nicht - ich bräuchte doch eine Antwort auf die allererste Frage ! Muß doch irgendwie möglich sein....

Danke

peppi
18.10.2001, 12:13
Hallo,

Du mußt bei den Spaltenbreiten des Nachschlagefelds die erste Spalte auf 0 setzen, dann erhältst Du die Angaben der 2. Spalte.

Olli12345
18.10.2001, 14:07
Ja das ist schon klar, aber dann sehe ich ja die Werte der ersten Spalte nicht mehr !(Namen)

siboern
19.10.2001, 22:25
Hallo Olli,
ist das Thema noch aktuell?
Gruß Siegfried

Olli12345
20.10.2001, 09:51
Ja, ist noch aktuell - habe leider noch immer keine Lösung gefunden ! Die Handbücher lassen einen da ziemlich im Stich !

Olli

siboern
24.10.2001, 14:25
Hallo Olli,
wenn Du immer noch Hilfe brauchst, solltest Du das Problem etwas ausführlicher beschreiben. Wie du aus meinem ersten Beitrag hast sehen können, habe ich nicht kapiert, um was es denn eigentlich geht. Du kannst gern auch per E-Mail auf mich zukommen.
Grüße Siegfried

Mattes
24.10.2001, 14:47
Hi Olli,

da gibt' nen simplen Trick: Tausch doch einfach die Spalten in der Ursprungstabelle.

Kannst auch hier mal nachsehen: Parameterabfrage??? (http://www.ms-office-forum.net/forum/showthread.php?s=&threadid=50104)