PDA

Vollständige Version anzeigen : Datenbank vollständig gesperrt


Frank S
15.10.2001, 16:20
Hallo,

ich habe momentan ein Problem mit meiner Datenbank. Ich habe einen neuen Datensatz eingeben wollen (ich wusste nicht, dass der Datensatz schon existierte). Anstelle der Fehlermeldung "Primärschlüssel existiert schon!" wurde mir der Fehler 3624 angezeigt ("Der Datensatz konnte nicht gelesen werden, da er momentan von einem anderen Benutzer gesperrt wird."). Diese Fehlermeldung ist mir vollkommen unverständlich - ich bin der einzige Nutzer!
Am schlimmsten ist, dass ich jetzt an überhaupt keine Daten der Datenbank mehr rankomme - immer erscheint dieser Fehler. (Andere bestehende Datensätze lassen sich auch nicht mehr editieren!) Ich weiss nicht, was ich tun soll, um wieder mit meinen Daten arbeiten zu können. Das Hilfsprogramm "Daten komprimieren und reparieren" hat nichts gebracht.
Für einen Tipp wäre ich sehr dankbar - bin schon ganz verzweifelt!
Danke - Frank

holgii
15.10.2001, 16:27
Hallo,

wende Dich mal vertrauensvoll an Deinen Server-Admin...
Der kann evtl. mit dem Server-Manager-Programm alle noch offenen Verbindungen zur .MDB-Datei löschen.

Frank S
15.10.2001, 17:38
Hallo holgii,

danke erst mal für Deine schnelle Antwort. Ich habe aber überhaupt keinen Server-Administrator!!! Ich sitze hier zu Hause ganz allein an meinem PC - ohne jedes Netzwerk. Weisst Du jetzt noch weiter?

Danke
Frank

courtino
15.10.2001, 17:46
Hey Frank, probiers mal dass du direkt in die Tabelle gehst und diesen Datensatz aus der Tabelle entfernst.
viel glück

Frank S
15.10.2001, 18:04
Hi Courtino,
hab ich schon alles probiert - funktioniert aber nicht. Habe gerade mal auf der "Access-Rettung"-Site nachgelesen. Ursache ist wohl ein falsch abgespeicherter Zeiger auf einen Datensatz. Einzige Möglichkeit ist wohl, die nicht betroffenen Datensätze in eine neue DB zu exportieren. Mal sehen, ob ich Glück habe :)
Frank

Frank S
15.10.2001, 18:17
HURRA, HURRA - meine Datenbank funktioniert wieder!!! Durch die Tipps auf der "Access-Rettung"-Seite habe ich alles wieder zum Laufen gebracht :)
Vielen Dank für die Hilfe!!!

Frank