PDA

Vollständige Version anzeigen : Ich werd' noch zum Hirsch...


Pittchen
13.08.2001, 14:07
Hey,
Seht mein Thema; In einem Bericht, der eine Rechnung ergeben soll, habe ich die Felder [Menge] und [VKPreisStück]; in einem ungebundenen Textfeld möchte ich nun den Gesamtpreis errechnen lassen mit der Formel:
=[Menge]*[VKPreisStück] und erhalte die Fehlermeldung #Name?; ich haben KEINEN Schreibfehler, noch sonst irgendeinen Zeichensetzungs- oder anderen Fehler.
Was ist da los? Danke im Voraus und
Gruß Pittchen

Birgit Dannenberg
13.08.2001, 14:23
Der Feldname sollte in diesem Fall n i c h t mit einem der Datenquelle übereinstimmen!

Vielleicht hilft Dir das weiter.
Birgit

hermi
13.08.2001, 14:23
Hallo Pittchen,

könnte es sein, dass in irgendeinem dieser Felder nichts drinsteht? Ist dies der Fall, weiß Access nicht womit es rechnen soll.
Um dies zu verhindern hat Access die Nz-Funktion (näheres siehe OnlineHilfe).
Deine Formel müsste dann so lauten:
=Nz([Menge]) * Nz([VKPreisStück])
Ich hoffe dies hilft dir weiter

cu hermi

Rainer Bruecklmaier
13.08.2001, 14:24
Hallo!
Haben die Berichtsfelder evtl. dieselben Namen wie vorhandene Tabellenfelder? Damit kommt Access nicht immer zurecht .-)

Grüße, Rainer

Stema
13.08.2001, 14:25
Hallo Pittchen,

ich nehme mal an, daß das berechnete Feld in einem Fuß steht (Gruppenfuß, Seitenfuß, Reportfuß...)!

Dann versuch mal:
=Summe([Menge])*Summe([VKPreisStück])

Stema
13.08.2001, 14:28
Da habe ich das doch glatt falsch verstanden.

Also, versuch mal:
= Me.txtMenge * Me.txtVKPreisStück

Setzt natürlich voraus, daß Du Deine beiden Textfelder im Report geanuso benennst. ;)

Phillip-Berlin
13.08.2001, 14:46
ich haben KEINEN Schreibfehler, noch sonst irgendeinen Zeichensetzungs- oder anderen Fehler.


:)

=[Menge]*[VKPreisStück] hast du sicherlich als steuerelementinhalt eingefügt

Menge und VKPreisStück sind datenfelder in der datenquelle und nicht objekt/feldbezeichnungen

hmmm jedenfalls funkt es so bei mir

Pittchen
13.08.2001, 15:25
Hallo, ihr Lieben( =Philipp, Stema, Rainer, hermi und Birgit); Dank für eure Antworten; ich werd' jetzt mal die verschiedenen Vorschläge durchgehen. Mal sehen was es war.
Gruß Pittchen

Pittchen
14.08.2001, 07:53
Moin Leute,
noch mal zu meinem Hirsch-Dasein, das ich glücklicherweise abwenden konnte:
Hermi, tausend Dank, Du hast den Treffer gelandet:
ich habe die Formel nach deinem Rat umgebaut, denn es waren tatsächlich Nullwerte inder Abfrage, die dem Bericht zugrunde liegt; Außerdem lasse ich jetzt in der Abfrage direkt rechnen, ist viiieell schneller; Die Formel heißt jetzt:
Preis: nz([Menge];0)*nz([VKPreisStück];0)

Gruß Pittchen