PDA

Vollständige Version anzeigen : Import funktioniert aus Excel, aber nicht in Abfrage importiert


Eviangel
30.06.2001, 15:59
Hallo,
weiß nicht wie das geht, bin Anfänger.
1. Machte es jetzt so
Habe 1 Tabelle in die immer wieder aus Excel Daten importiert werden. Machte daraus eine ja/nein Abfrage.
In dem dazugehörigen Formular sollen Daten mit "ja-Ankreuzung" nicht mehr angezeigt werden.
Erstellte ein "Anfängermakro", wo ich Daten aus Excel importiere. Geht alles wunderbar in die Tabelle, Daten werden importiert.
Nur in der Abfrage sind keinerlei Daten drin und im Formular dann ja auch nicht.
Weiß nicht, wie ich das lösen kann.

2. So wollte ich es ursprünglich haben
Eigentlich 2 Tabellen, die 1:1 verknüft sind (derselbe Primärschlüssel).
Wollte ein Makro machen, das Daten folgendermassen importiert:
Die 1. Tabelle, normaler Import aus Exceldatei (1.xls) mit Primärschlüsselerkennung.
Die 2. Tabelle, da sollte nur ein bestimmtes Feld von diesem Excelimport(1.xls) (Primärschlüsselfeld) importiert werden.
Also das Makro soll sich auf beide Tabellen gleichzeitig beim Import beziehen.
Kann man Felder (Spalten) importieren? Kann kein Bezug eingeben wie A2:A17, da die Excelimporttabellen immer wieder
unterschiedlich in der Größe sind, einmal bis A20, dann evtl. bis A40, ist unterschiedlich. Wie macht man sowas?
Geht das überhaupt?

Die Abfrage muß ich wie oben beschrieben machen, mit ja/nein-Auswahl.
Wer weiß Rat, würde mich sehr freuen.
Evi

Klaus-Dieter
30.06.2001, 19:30
Hallo Evi,

hast Du schon mal versucht, Deine Excel-Tabelle zu verknüpfen, nicht zu importieren?
Dadurch überträgst Du Deine Excel-Daten 1:1. In Access kannst Du sie dann weiterbearbeiten. Ich denke das würde insgesamt viel Aufwand vermeiden.