PDA

Vollständige Version anzeigen : Netzwerkfähige MDB (verknüpfungsproblem)


HAFISENIOR
01.05.2001, 18:54
Hallo

Ich habe auf einem Server die Daten-mdb und auf 3 anderen die Programm-mdb installiert.
Zusätzlich ist auf dem Server auch die Daten-mdb abgelegt (Sekretärin arbeitet lokal darauf ???).
Jede Programm-mdb stellt beim Start die Verknüpfung zur Daten-mdb her. Das funktioniert überall (der Pfad der Daten.mdb = X:\SMP\). Nur, wenn das Programm auf dem Server direkt gestartet wird, scheint die Verknüpfung mit (E:\SMP\) nicht zu funktionieren.
Das nächste Problem ist, daß das Berechnen/Formatieren und Öffnen der Berichte (mit Diagrammen)auf den vernetzten PC's einfach zu lange dauert.
Bin auf Netzwerken einfach ein kompletter Neuling.
Danke im Voraus für Ratschläge und Tipps.

Günni
01.05.2001, 19:21
Also Verknüpfungsproblem kann ich mir nicht erklären. Wenn auf dem Server ein entsprechendes Netzwerkverzeichnis existiert, sollte das auch funktionieren.

Zum Thema Performace: das Problem ist, dass Access zu den sog. Desktop-Datenbanken gehört. Das heißt, obwohl die Daten auf dem Server liegen, werden sie auf den Clients verarbeitet. Dazu müssen die gesamten Daten der betroffenen Tabellen natürlich übers Netzwerk zu den Rechnern geschaufelt werden. Das dürfte der Grund für die schlechte Performance sein. Abhilfe zu schaffen ist hier schwierig. Zum einen könnte man auf ne richtige Server-Datenbank umsteigen (wie zum beispiel den SQL-Server). Dabei kann man dann zwar weiter mit den Prog-MDB´s arbeiten, jedoch gewinnt man nicht so viel an Geschwindigkeit. Richtig schnell wird das ganze dann erst, wenn man auch die Progrs austauscht (zum Beispiel durch eine VB-Anwendung). Allerdings ist dazu ein komplettes Redesign mit einem erheblichen Aufwand notwendig.

Es wäre aber auch denkbar, nur Teile der Anwendung nach VB auszulagern und als DCOM-Komponente zu nutzen ... ist aber auch recht komplex und lohnt sich nur bei zeitaufwendigen Datenbankzugriffen (Abfragen über viele Tabellen)

Wenn die all das zu aufwendig ist, kannst du nur versuchen, die Datenzugriffe zu vereinfachen (einfachere Abfragen). Dazu ist aber (wie übrigens auch zu den ganzen anderen Punkten) ein relativ umfangreiches Fachwissen erforderlich. Das läßt sich hier auch schlecht pauschal vermitteln.

PS:
Im Zweifelsfall kannst Du mich über mg@mgcss.de erreichen, falls Du weitere Hilfe benötigst.

klemens
02.05.2001, 13:32
hi,

hatte selbes problem:

lösung:
auf dem lokalen ein "subst X: c:\pfad " ( in die autoexec ) einrichten.
dann verhälts sichs von überall her gleich...

mfg
.klemens

HAFISENIOR
03.05.2001, 16:39
Hi Günni, Klemens

Vielen Dank für Eure Lösungsvorschläge.
Günni's (leichtsinnigem ?)Angebot, weitere Hilfe in zu gewähren, wird wohl ein e-Mail folgen. :-)
Anscheinend gibt's außer mir auch noch jemanden, der DOS-Befehle kennt und im Gegensatz zu mir, auch noch anzuwenden weiß (Klemens).

Günni
03.05.2001, 18:14
kein Problem ... immer her damit ;-) ... kann nur machmal etwas dauern mit der Antwort