PDA

Vollständige Version anzeigen : Suche VBA: "Abstand zwischen Zellen zulassen" deaktivieren


donbosco
27.08.2019, 08:11
Hallo, ich suche den passenden VBA-Befehl zur Deaktivierung der Tabellen-Option "Abstand zwischen Zellen zulassen". Früher ging mal .spacing = -1. Das geht aber leider nicht mehr. Auch die Makroaufnahme liefert mir nur spacing = 0. Das führt aber nicht zum gewünschten Ergebnis. Ich habe immer noch die Doppelstriche in der Tabelle. Für Hilfe wäre ich sehr dankbar.

wb425
27.08.2019, 09:30
Falscher Artikel, ich versuche es gleich nochmal...

donbosco
27.08.2019, 09:34
ja, genau das habe ich gemacht. Mit Spacing = 0 ist der Haken in den Optionen der Tabelle nicht weg. Den möchte ich mittels VBA wegbekommen.

wb425
27.08.2019, 09:48
Hallo donbosco,
wer lesen kann... den Vorschlag mit der Aufzeichneung hätte ich mir sparen können.

Das Makro habe ich mit Office 2016 aufgezeichnet.
Dann habe ich das nochmals auf einem alten PC mit Word 2010 probiert. Das Verhalten war anders als du es beschrieben hast. Hast du das mal mit einer anderen Datei und einer neuen Tabelle versucht? Liegt es womöglich an deiner Datei / Tabelle? Hast du die Anwendung mal neu gestartet?
Bei meiner Version führt spacing=0 zum Verschwinden der doppelten Linien.

donbosco
27.08.2019, 09:53
Nein, es funktioniert definitiv nicht. Nach dem Ausführen von spacing = 0 ist der Abstand 0 aber der Parameter "Abstand zwischen Zellen zulassen" ist immer noch aktiviert. Wie bekomme ich den Haken weg?

wb425
27.08.2019, 11:03
Zwei Linien mit Abstand 0. Da wäre ich nie drauf gekommen.
Ich hätte da noch einen Workaround von einem anderen Board:

https://www.msofficeforums.com/word-vba/32950-allow-spacing-between-cells.html

dort der 4. Artikel:

https://www.msofficeforums.com/107580-post4.html?

Gerhard H
27.08.2019, 12:43
Hallo zusammen,

eine Rückmeldung von mir da ich mittlerweile auch vergeblich rumexperimentiert habe:

(Tabelle).spacing = 0 bewirkt bei mir (Word 2010) ein Zusammenfallen der Linien, so dass man zwar keine doppelten, aber stärkere Linien hat.

Ich hab dann rumexperimentiert mit

(Tabelle).spacing = 0
(Tabelle).Borders.InsideLineWidth = wdLineWidth025pt
(Tabelle).Borders.OutsideLineWidth = wdLineWidth025pt

was leider nur beinah klappt. Die senkrechten Innenlinien bleiben bestehen. Sie wegzukriegen ist mir nicht gelungen. Auch nicht mit Wolfgangs erstem Link.

Aber der zweite funktioniert bei mir wunderbar. Danke dafür.

donbosco
27.08.2019, 12:50
VBA bietet mir den Befehl Allowspacing erst gar nicht an.
Den hätte ich auch gekannt. Anscheinend ist dieser Befehl nicht implementiert. Dann lasse ich mir am Ende meines Makros den Dialog für die Tabellenoptionen öffnen. Das reicht für mich. Danke für die schnelle Unterstützung.

Gerhard H
27.08.2019, 14:42
Hallo DonBosco,

das gibts schon ab und zu, dass ein Parameter von VBA-Intellisense nicht angeboten wird. In diesem Fall kannst du das trotzdem notieren und es funktioniert unter der Voraussetzung, dass bei Makrostart die Schreibmarke in der Tabelle steht. Gemäß des zweiten Links von Wolfgang, ohne dass man das Dialogfeld zu Gesicht bekommt.

donbosco
27.08.2019, 15:10
Das ist mir neu, selbst in der Hilfe finde ich den Allowspacing-Befehl nicht. Aber mein Makro öffnet jetzt den Dialog. Dort muss ich nur noch den Haken entfernen fertig. Mit der nächsten 365-Office-Version ist das ggf. behoben.