PDA

Vollständige Version anzeigen : Falsches Zeichen bei Speichern als CSV


Noepes
08.12.2017, 07:23
Guten Morgen in die Runde,

Vorbemerkung: Ich nutze Office 2016.

Wenn ich eine Excel-Datei (zB Liste 19.xlsx) öffne und diese anschließend als CSV-Datei speichere, dann ist das Trennzeichen das Semikolon, so soll's auch sein.

Dabei ist es egal ob ich den ersten oder zweiten Weg beschreite um die CSV-Datei zu erzeugen:

1: Datei - Speichern unter - Ordner auswählen - Dateityp CSV (Trennzeichen getrennt)
2: Datei - Exportieren - Dateityp ändern - CSV (Trennzeichen getrennt)

Wenn ich den Vorgang per Makrorecorder aufzeichne , dann entsteht dieser Code:


Sub Makro2()
'
' Makro2 Makro
'
ChDir "H:xxxyyy"
Workbooks.Open Filename:="H:xxxyyyListe 19.xlsx"
ActiveWorkbook.SaveAs Filename:= _
"H:xxxyyyListe 19.csv", FileFormat:=xlCSV, _
CreateBackup:=False
ActiveWindow.Close
End Sub


Beim Ausführen dieses Codes wird aber mit Komma und nicht mit Semikolon gespeichert. Und das ist für die weitere Verarbeitung eine Katastrophe.

Hat jemand eine Idee, wie ich dem Makrocode beibringen kann das Semikolon zu verwenden?

Danke vorab!

Gruß, Noepes

Noepes
08.12.2017, 07:28
Asche auf mein Haupt, ich hab's gefunden - hat sich also erledigt.

http://www.ms-office-forum.net/forum/showthread.php?t=329291
(http://www.ms-office-forum.net/forum/showthread.php?t=329291)

RPP63neu
08.12.2017, 07:29
Moin!
Die .SaveAs-Methode hat den benannten Parameter Local:=
Setze diesen mal auf True

Gruß Ralf

RPP63neu
08.12.2017, 07:29
Na gugge,
war ja auch ich ;)