PDA

Vollständige Version anzeigen : Dynamischer Verweis


Peacemaster
02.09.2017, 00:54
Moin liebes Forenteam,

ich habe schon ziemlich viel getüftelt, aber bin bisher noch nicht auf die Lösung gekommen.

Folgendes Problem:
LEVEL 1 LEVEL 2 LEVEL 3 WERT SUMME
PHARAO REGENT1 BAUER1 1 1
PHARAO REGENT1 BAUER1 1 1
PHARAO REGENT1 BAUER1 0,5 0,5
PHARAO REGENT1 BAUER1 1,2 1,2
PHARAO REGENT1 BAUER1 1 1
PHARAO REGENT1 BAUER1 1 1
PHARAO REGENT1 BAUER1 1 1
PHARAO REGENT1 BAUER1 1,2 STOP 7,9
PHARAO REGENT1 BAUER2 1 1
PHARAO REGENT1 BAUER2 0,625 STOP 1,625
PHARAO REGENT1 BAUER3 1 1
PHARAO REGENT1 BAUER3 1 1
PHARAO REGENT1 BAUER3 1 1
PHARAO REGENT1 BAUER3 1 1
PHARAO REGENT1 BAUER3 1 STOP 5
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 0,45 0,45
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 1
PHARAO REGENT2 BAUER4 1 STOP 13,45


Ich möchte den Wert haben, der den einzelnen Bauern in summe zugeordnet wird. Mit Wenn-Funktion haben ich bereits die STOP Punkte gesetzt

=WENN(UND(A16=A17;B16=B17;C16=C17);D16;"STOP").

Dann habe ich die zugehörigen Summen zu den einzelnen Bauern gebildet

=WENN(E16="STOP";SUMME(D$9:D16)-SUMME(F$8:$F15);"")

Jetzt möchte ich aber die Ausgabe in der Zeile des ersten Bauern 1 haben, damit ich das später über die Aufklappfunktion direkt dem obersten zugeordent habe.
Das heiißt zum Beispiel die Summe 7,9, die jetzt noch in der letzten Zeile der Bauern 1 steht, soll dann in der ersten Zeile der Bauern 1 stehen.


Kann mir dabei jemand helfen? Wäre super phat :)

WS-53
02.09.2017, 06:13
Hallo,

geht viel einfach als du denkst und Stoppunkte sind dazu nicht notwendig.

=WENN(C2<>C1;SUMMEWENNS(D2:D31;C2:C31;C2);"")

Sofern bei einem Bauern mehr als 30 Positionen vorkommen können, muss du halt D31 und C31 entsprechend erweitern. Ich habe aber bewusst nicht die gesamten Spalten definiert, da dann die Formel nur unnötig viele Zeilen berücksichtigen müsste.

Peacemaster
02.09.2017, 11:32
Super geil, hat perfekt geholfen :))
Und deutlich schlanker als mein Weg :):) :)
Herzlichen Dank und nen schönes WE Dir :)
LG