PDA

Vollständige Version anzeigen : SUMMEWENN-Funktion erweitern


Töffi
01.09.2017, 09:24
Hallo und guten Morgen,

ich habe folgende Funktion: =(D17)/(SUMMEWENN(D19: D29;"<>";A19:A29))
und möchte nun die Bereiche in Spalte D und A um weitere Zeilen erweitern.

Diese Zeilen grenzen jedoch nicht an den Bereich 19-29 an.
Es geht also mit zahlreichen Zeilenunterbrechungen bis etwa Zeile 177 weiter.
Wenn ich die entprechenden Bereiche einzeln markiere bekomme ich die Fehlermeldung das die Funktion zu umfangreich sei.

Gibt es hierfür eine Möglichkeit, sei es direkt oder auf Umwegen?

Vielen Dank schon mal vorab, Gruß Töffi

steve1da
01.09.2017, 09:36
Hola,

dazu bedarf es einer genauen Beschreibung, am Besten anhand einer Beispieldatei.

Gruß,
steve1da

Töffi
01.09.2017, 09:59
Sorry, ich weiß leider nicht wie ich meine Exeltabelle hier "reinkopieren" kann, daher versuche ich es zu beschreiben:

Spalte C beinhaltet in den Zeilen 4+5+6+11+12+15 etc. feststehende Werte, (Verknüpfungen aus einer anderen Datei) die nur dann addiert werden sollen,
wenn sich in der ensprenden Zeile in Spalte K eine Zahl befindet.

Habe gerade bemerkt, daß meine Formel alle Werte aus C addiert, auch wenn in K gar keine Eingabe erfolgt ist.

steve1da
01.09.2017, 10:01
Hola,

unter dem Antwortfenster gibt es den Button "Erweitert" - dort können Anhänge hochgeladen werden.

Gruß,
steve1da

Töffi
04.09.2017, 19:24
Guten Abend,
versuche mal die Tabelle anzuhängen

Töffi
04.09.2017, 19:33
Wenn in Spalte F-J Zahlen eingetragen werden, werden diese in Spalte K addiert.
Die Zahlen aus Spalte C haben ihren Ursprung in einer weiteren verknüpften Datei.
Es sollen nun in Zelle B6 nur diejenigen Zahlen (Zellen) aus Spalte C addiert werden, denen in Spalte K eine Zahl gegenübersteht.

Töffi
04.09.2017, 19:42
In folgender Tabelle funktioniert es so, wie ich es haben möchte.
Die Übertragung gelingt mir nicht.

Töffi
07.09.2017, 21:00
Hallo,
hat noch jemand eine Idee zu meinem Problem?

Gruß Töffi

steve1da
08.09.2017, 06:32
Hola,

deine Summewenn() Formel rechnet falsch, da alle Zellen in C addiert werden.

=SUMMEWENN(K9:K21;">0";C9:C21)

Was du mit "übertragen" meinst, erschließt sich mir nicht.

Edit: wenn es darum geht, die Summen bei den Orten nicht mit zu berücksichtigen, ginge das z.B. so:

=SUMMENPRODUKT((K9:K30>0)*(LINKS(B9:B30;3)<>"ort")*(C9:C30))

Gruß,
steve1da

caplio
08.09.2017, 06:39
Ich hoffe ich habe das Problem verstanden. Schau dir mal die anhängende Datei an.

steve1da
08.09.2017, 06:46
Hola,

@caplio: deine Summe der Zahlen aus Spalte C, denen eine Zahl in Spalte K gegenübersteht ist viel zu hoch. Durch >=0 zählst du eben auch die Zellen mit, deren Summe 0 ist - also alle.

Gruß,
steve1da

caplio
08.09.2017, 12:02
Oja, stimmt. War noch zu früh. :)

Töffi
08.09.2017, 23:26
Guten Abend zusammen,
steve1da, Deine Lösung funktioniert gut, Danke!
Besteht denn jetzt auch die Möglichkeit, die anderen Orte mit einzubeziehen, bzw zu addieren, auch wenn die Zellen nicht direkt angrenzen?

Der kursive Wert aus C 22 z.B. ist eine Zwischensumme, die nicht mit addiert werden soll.

Töffi
17.09.2017, 15:31
Guten Tag,
ich Versuche es nochmal.
Formel funktioniert gut, läßt sich jedoch nicht für weitere Orte erweitern.
Ich bekomme die Fehlermeldung, das ich zu viele Argumente für diese Funktion habe.
Gibt es hier eine Lösung?

steve1da
17.09.2017, 15:39
Hola,

ohne zu sehen was du versucht hast, oder was du vorhast, wird das schwer.

Gruß,
steve1da

Drogist
17.09.2017, 18:03
Ich schließe mich steve an ...
Was willst du denn als Ergebnis haben?
Ich komme auf der Basis des Workbooks Liste I auf dieses Ergebnis:
Ort I 3,0913
Ort II 5,9672
... aber wahrscheinlich habe auch ich dich nicht richtig verstanden. :(

Töffi
18.09.2017, 09:12
Guten Morgen steve1da,
so sah mein Versuch aus die von Dir vorgeschlagene Lösung (funktioniert super) zu erweitern.

=K6/SUMMENPRODUKT((K9:K21;K23:K26>0)*(LINKS(B9:B21;B23:B26;3)<>"ort")*(C9:C21;C23:C26))

damit ich weitere, nicht zusammenhängende Zeilen miteinbeziehen kann.
Gruß Töffi

steve1da
18.09.2017, 09:19
Hola,

warum nimmst du nicht einfach meine Formel? Dort wird von K9 bis K30 alles summiert, wo in Spalte A nicht "Ort" steht.

Gruß,
steve1da

Töffi
03.01.2018, 13:33
Hallo und guten Tag,
sorry vorab leider war ich beruflich ziemlich gebunden, sodass ich mich erst jetzt wieder mit Excel beschäftigen kann.

Die Lösung von steve1da funktioniert prima für die erste Region. Wenn ich die Flächen weiterer Regionen mit hinzunehmen möchte (leider keine zusammenhängende Zellen) klappt dies nicht.
Vielen Dank vorab, Gruß Töffi

steve1da
03.01.2018, 13:36
Hola,

es soll jetzt also noch Region 2 mit reingenommen werden? Wenn ja, das habe ich dir doch schon beantwortet.

Gruß,
steve1da

Töffi
03.01.2018, 13:38
P.S.: zwischen den Regionen stehen weitere Bereiche mehrerer Zeilen, die nicht miteinbezogen werden sollen.

steve1da
03.01.2018, 13:43
Hola,

das sind so Infos, die vorher kommen sollten.
Allerdings für den konkreten Fall noch zu vage. Was soll denn nicht berücksichtigt werden?

Gruß,
steve1da

Töffi
03.01.2018, 14:35
Sorry,
alles was nicht in den grün gefärbten Zellen steht sollte nicht berücksichtigt werden.

Töffi
03.01.2018, 14:37
Also die Flächen der Regionen sollen in der Formel berücksichtigt werden, nicht die Regionen selbst.

lupo1
03.01.2018, 14:37
Verabschiede Dich von Deiner Idee, nicht zusammenhängende Bereiche auszuwerten (da gibt es nur wenige Funktionen, die das können). Du könntest eine Hilfsspalte anhängen, in welcher eine 1 steht, und die 1 ausschließen (so wie "Ort" eben auch).

Töffi
03.01.2018, 14:59
Daran habe ich auch schon gedacht, jedoch würde dies die Änderung mehrerer hundert Verknüpfungen erfordern. Daher hoffe ich auf eine andere Möglichkeit.
Gruß Töffi

Töffi
11.01.2018, 19:12
Guten Abend,
hat noch jemand eine weitere Idee ohne die Einrichtung einer Hilfsspalte?
Dies würde mir eine Menge Nachfolgearbeit ersparen.

Schönen Abend, Gruß Töffi