PDA

Vollständige Version anzeigen : Daten in 2 Dateien abgleichen


Shorty0811
31.08.2017, 20:54
Hallo liebe Com,

Irgendwie habe ich gerade eine Denkfehler und stecke fest. Ich habe folgendes vor.

In Datei 1 ist in Spalte A eine Tabelle angelegt, wenn ich da Daten hinzufüge wird die Tabelle auch automatisch verlängert - passt soweit also alles.

Nun will ich diese Daten in Datei 2 haben. Wenn in Datei 1 dann etwas geändert wird soll dies automatisch in Datei 2 übernommen werden.

Und jetzt kommt der Denkfehler denn ich bekomme zwar die Tabelle übertragen, nur der Inhalt wird leider nicht aktualisiert, geschweige denn neue Daten hinzugefügt.

Bin für jede Hilfe dankbar.

Gruß Shorty

Drogist
01.09.2017, 01:40
Moin,
auch wenn ich in diesem Moment in der Daten-Redundanz keinen Sinn sehe: Das ist mit Power Query, -> http://www.excel-ist-sexy.de/power-query-das-add-in/ sehr gut machbar.

Shorty0811
01.09.2017, 10:24
Hallo Drogist,

erstmal Danke für den Tipp.

Um es ausführlicher zu machen: Die Daten von Datei 1 werden in mehr als 50 Dateien benötigt und ich habe keine Lust jedesmal alle zu aktualisieren.

LG Shorty

Jonas0806
01.09.2017, 10:38
Hallo Shorty,

wenn es keine intelligente Tabelle ist, z.B. so
=WENNFEHLER(INDEX(Tabelle1!$A$2:INDEX(Tabelle1!$A:$A;VERWEIS(2;1/(Tabelle1!A:A<>"");ZEILE(A:A)));ZEILE(A1));"")

Formel runter ziehen.