PDA

Vollständige Version anzeigen : SVERGLEICH: Werte nicht verändern, wenn in Vergleichsliste nicht vorhanden


dertobinator
31.08.2017, 08:44
Hallo, liebe Excelperten!

Heute bitte ich Euch bei folgendem Problem um Hilfe:

Über SVERGLEICH versuche ich über die Artikelnummer, eine Preisliste zu aktualisieren.
Meine Ausgangsliste weist jedoch auch Artikelnummern auf, die in der Aktualisierungsliste nicht existieren.Ich möchte nun, dass Excel die Preise in der Ausgangsliste unberührt lässt und NICHT löscht bzw. "0" reinschreibt, wenn er die Artikelnummer in der Vergelichsliste nicht findet.
Mein bisherige Formel lautet:

=SVERWEIS(A2;Preisliste!$A$2:$F$19809;6;FALSCH)

Was ist des Rätsels Lösung?

steve1da
31.08.2017, 08:49
Hola,

wenn die Nummer nicht gefunden wird erscheint #NV - da wird nichts gelöscht und es erscheint auch keine 0.

Gruß,
steve1da

dertobinator
31.08.2017, 09:07
Hi,okay, dann erscheint #NV.
Wie gesagt: Das soll da aber nicht stehen, sondern dann - wel nicht gefunden -der Originalpreis, der schon vorher dort stand.

steve1da
31.08.2017, 09:12
Hola,

=wennfehler(SVERWEIS(A2;Preisliste!$A$2:$F$19809;6;FALSCH);Zelle_mit_Originalpre is)

Gruß,
steve1da

dertobinator
31.08.2017, 09:15
Hey, super, vielen, vielen Dank mal wieder an Dich!

:)