PDA

Vollständige Version anzeigen : WENN Funktion Monatlich


Qualitäter
28.08.2017, 08:58
Hallo Leute,

wer hätte das gedacht - ich brauch eure Hilfe bei Excel.
Ich habe in Spalte A Datumsangaben wie auf der Grafik zu sehen ist. Ich möchte gern, das Excel die Summe aller Zahlen in den Spalten B und C bildet, vorausgesetzt sie sind aus dem Monat April (also =WENN April dann Summe...).

Wie könnte die Funktion aussehen?
Vielen Dank für eure Hilfe!

https://s1.imagebanana.com/file/170828/nV2qFyac.JPG (https://www.imagebanana.com/s/798/nV2qFyac.html)

steve1da
28.08.2017, 09:03
Hola,

=SUMMENPRODUKT((MONAT(A1:A4)=4)*(B1:C4))
Wenn auch das Jahr berücksichtigt werden soll:

=SUMMENPRODUKT((MONAT(A1:A4)=4)*(JAHR(A1:A4)=2017)*(B1:C4))

Gruß,
steve1da

Qualitäter
28.08.2017, 09:07
DAS nenn ich schnell!!!
GRACIAS :)

RPP63neu
28.08.2017, 09:15
Moin!
Nur ergänzend:
Es geht auch mit einer Hilfsspalte =Monat(A2)
Danach Summewenn()+Summewenn()
Vorteil:
Man kann ganze Spalten in der Formel nutzen.
Summenprodukt sollte immer auf einen kleinen Bereich angewandt werden, um Excel nicht auszubremsen.
<b>Tabelle4</b><br /><br /><table border="1" cellspacing="0" style="font-family:Calibri,Arial; font-size:11pt; background-color:#ffffff; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:71px;" /><col style="width:45px;" /><col style="width:45px;" /><col style="width:53px;" /><col style="width:28px;" /><col style="width:47px;" /><col style="width:61px;" /><col style="width:61px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td><td >G</td><td >H</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="background-color:#c6e0b4; ">Datum</td><td style="background-color:#c6e0b4; ">Wert1</td><td style="background-color:#c6e0b4; ">Wert2</td><td style="background-color:#c6e0b4; ">Hilfssp.</td><td >&nbsp;</td><td style="background-color:#c6e0b4; ">Monat</td><td style="background-color:#c6e0b4; ">Summe1</td><td style="background-color:#c6e0b4; ">Summe2</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="text-align:right; ">29.03.2017</td><td style="text-align:right; ">45</td><td style="text-align:right; ">96</td><td style="text-align:right; ">3</td><td >&nbsp;</td><td style="text-align:right; ">3</td><td style="text-align:right; ">141</td><td style="text-align:right; ">141</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="text-align:right; ">04.04.2017</td><td style="text-align:right; ">27</td><td style="text-align:right; ">27</td><td style="text-align:right; ">4</td><td >&nbsp;</td><td style="text-align:right; ">4</td><td style="text-align:right; ">184</td><td style="text-align:right; ">184</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="text-align:right; ">21.04.2017</td><td style="text-align:right; ">51</td><td style="text-align:right; ">79</td><td style="text-align:right; ">4</td><td >&nbsp;</td><td style="text-align:right; ">5</td><td style="text-align:right; ">128</td><td style="text-align:right; ">128</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="text-align:right; ">03.05.2017</td><td style="text-align:right; ">90</td><td style="text-align:right; ">38</td><td style="text-align:right; ">5</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >D2</td><td >=MONAT(A2)</td></tr><tr><td >G2</td><td >=SUMMEWENN(D:D;F2;B:B)+SUMMEWENN(D:D;F2;C:C)</td></tr><tr><td >H2</td><td >=<span style=' color:008000; '>SUMMENPRODUKT((<span style=' color:#0000ff; '>MONAT(A$2:A$100)</span>=F2)</span>*B$2:C$100)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8 </a>

Gruß Ralf

lupo1
28.08.2017, 09:47
Statt steve1da's (25% schnellerem!)

=SUMMENPRODUKT((MONAT(A1:A4)=4)*(JAHR(A1:A4)=2017)*B1:C4)

finde ich auch

=SUMMENPRODUKT((--TEXT(A1:A4;"JMM")=1704)*B1:C4)

ganz nett, da es a) kürzer ist und b) nur einmal das Argument A1:A4 enthält.