PDA

Vollständige Version anzeigen : Formel


ciappal
25.08.2017, 07:48
Hallo,

ich brauche noch eine letzte Formel in der Spalte AE7
Dort brauche ich die Summe der Spalte Y, welche aber zuerst mit dem Gewicht in der Spalte Z multipliziert werden soll.

ZB: Y2*Z2 + Y3*Z3 + Y4*Z4 + Y5*Z5 usw....

vielen dank noch einmal :)

Jonas0806
25.08.2017, 07:51
Hallo,

=SUMMENPRODUKT(Y2:Y5*Z2:Z5)

ciappal
25.08.2017, 07:59
Perfekt, danke! Ich brauche diese formel bis zur Zeile 999. Wenn ich aber die 5 mit 999 ersetze kommt mir #NV ?

Jonas0806
25.08.2017, 08:00
Hallo,

Du musst die 5 natürlich 2x ersetzten. Also


=SUMMENPRODUKT(Y2:Y999*Z2:Z999)

ciappal
25.08.2017, 08:34
Jetzt habe ich den fehler gefunden. Habe die Spalte Z bis zur Zeile 999 mit Formeln, ab Zeile 30 ist dort aber #NV drinnen, weil ich nicht mehr daten habe...
Die Formel passt so, wir müssten aber noch hinzufügen, dass #NV nicht berücksichtigt wird

Jonas0806
25.08.2017, 08:47
Hallo,

ungetestet
{=SUMMENPRODUKT(wennfehler(Y2:Y999;)*wennfehler(Z2:Z999;))}

Als Matrixformel abschließen. {} nicht mit einegeben, sonder die Formel mir Strg+Shift+Enter abschließen.

ciappal
25.08.2017, 08:54
Hat geklappt, vielen dank ;)

BoskoBiati
25.08.2017, 09:23
Hi,

Habe die Spalte Z bis zur Zeile 999 mit Formeln, ab Zeile 30 ist dort aber #NV drinnen

Dann schalte den Fehler schon in der Formel aus, dann muß man keine Klimmzüge machen!

ciappal
28.08.2017, 17:22
Hallo, ich habe noch etwas vergessen. Dir formel passt soweit, aber es sollte zum Ergebniss noch der Betrag aus Zelle AE6 dazugezählt werden.

Also
Y2:Y999 mal Z2:Z999
#NV soll nicht beachtet werden
zum schluss soll zelle AE6 addiert werden

Wäre super wenn es ohne matrixformel gehen würde, da ich diese nicht selber nachvollziehen bzw evtl noch nachbearbeiten kann

vielen dank nocheinmal

Oge
28.08.2017, 19:45
Hallo c...,

zu: ... aber es sollte zum Ergebniss noch der Betrag aus Zelle AE6 dazugezählt werden.
{
=SUMMENPRODUKT(wennfehler(Y2:Y999;)*wennfehler(Z2:Z999;))+ABS(AE6)
}

zu:... da ich diese nicht selber nachvollziehen bzw evtl noch nachbearbeiten kann.
Das kann man doch ändern:

a) nachvollziehen
Durch den Abschluss einer Formel als Matrixformel (mit Strg+Shift+Enter) kann ich für Parameter von Funktionen, die an dieser Stelle einen Zellbezug oder einzelnen Wert erwarten, einen Bereichsbezug oder eine Matrix eintragen.
Falls die Funktion im Normalfall einen einzelnen Wert zurückgibt wird bei einer Matrixfunktion eine Matrix zurückgegeben.
In deinem Beispiel erwartet die Funktion WENNFEHLER als ersten Parameter einen einzelnen Wert und gibt, falls es sich um einen Fehlereintrag handelt den zweiten Parameter wieder (hier "").
Durch den Abschluss der Formel als Matrixfunktion kann ich als ersten Parameter einen Bereich eintragen und erhalte als Ergebnis ein Matrix mit den ursprünglichen Werten bei denen allerdings Fehlerwerte durch "" ersetzt wurden. Diese werden in der folgenden Multiplikation und Summierung durch 0 ersetzt.

b) nachbearbeiten
Einfach nach jeder Änderung der Formel diese mit Strg+Shift+Enter abschliessen.