PDA

Vollständige Version anzeigen : Sverweis - eindeutig bei mehreren Suchergebnissen


Hiasl
24.08.2017, 08:41
Hallo zusammen :winken:

Ich finde im Netz leider keine Antwort auf meine Frage, also versuch ich's hier mal:

Ich denke, der Screenshot sagt schon Einiges.

Sverweis findet ja alle Zellen in Spalte A, die teilweise mit C1 übereinstimmen und gibt dann den ersten Fund aus.

Mein Problem, wenn C1 in mehreren Zellen der Spalte A vorhanden ist, soll Excel mir das irgendwie mitteilen oder einen Fehler ausgeben. Erst, wenn in C1 so viel eingegeben wird, dass nur noch ein Ergebnis vorhanden ist, soll Excel einen Wert ausgeben.

Geht das irgendwie? :sos:

:) Vielen Dank schon Mal! :)

steve1da
24.08.2017, 08:43
Hola,

also ich kann den Screenshot nicht sehen.

Gruß,
steve1da

Hiasl
24.08.2017, 08:49
Jetzt?

steve1da
24.08.2017, 08:56
Hola,

=WENN(ZÄHLENWENN(A1:A15;"*"&C1&"*")>1;"";SVERWEIS("*" & C1 & "*";A:B;2;FALSCH))

Gruß,
steve1da

BoskoBiati
24.08.2017, 08:56
Hi,

=WENN(ZÄHLENWENN(A:A;"*"&C1&"*")=1;SVERWEIS("*"&C1&"*";A:B;2;0);"")

Hiasl
24.08.2017, 09:37
Suuuupeeer :grins: :grins: