PDA

Vollständige Version anzeigen : Formel


ciappal
24.08.2017, 07:51
Hallo Leute,

ich hätte noch eine Bitte.
Ich habe einen SVERWEIS auf einen anderen Tab, wo mir das Gewicht einer Artikelnummer ausgelesen wird. Hier die Formel :
=SVERWEIS(C2;BASE!A:C;3;FALSCH)

Ich müsste die Formel jetzt erweitern, und zwar dass alle Artikelnummern welche mit PAC und mit OLIO beginnen, oder mit S0 enden durch 10 dividiert werden. kann mir jemand weiterhelfen?

beispiele für Artikelnummern
PACPROMO
PACTROED
OLIOMOT
G 859742S0
F 963147S0

vielen Dank schon mal

steve1da
24.08.2017, 07:54
Hola,

wie willst du denn "PACPROMO" durch 10 dividieren?

Gruß,
steve1da

ciappal
24.08.2017, 08:33
Ich habe eine beispieldatei angehängt.
In Z2 soll mir zb das gewicht der artikelnummer in C2 angegeben werden.
Das habe ich durch den SVERWEIS schon gelöst.

Was noch zur formel in Z2 hinzugefügt werden sollte ist dass alle Artikelnummern welche mit PAC oder mit OLIO beginnen oder mit S0 enden durch 10 dividiert werden

vielen Dank nocheinmal

steve1da
24.08.2017, 08:37
Hola,

da alle deine Sverweise #NV ergeben, bleibt nur raten:

=SVERWEIS(C2;BASE!A:C;3;FALSCH)/WENN(ODER(LINKS(C2;3)="pac";LINKS(C2;4)="olio";RECHTS(C2;2)="s0");10;1)

Gruß,
steve1da

BoskoBiati
24.08.2017, 08:43
Hi,

da würde ich Dir empfehlen, diesen Beitrag: http://ms-office-forum.net/forum/showthread.php?t=345296 und die Lösungen durchzuarbeiten, daraus kannst Du die Formel leicht ableiten!

ciappal
24.08.2017, 14:13
hat geklappt! vielen dank an alle die geholfen haben ;)