PDA

Vollständige Version anzeigen : Formel für Summe unter Bedingungen


ciappal
23.08.2017, 14:14
Hallo Leute,

ich bräuchte mal wieder eine Formel, komme aber nicht weiter.

edit: habe mich falsch ausgedrückt, so sollt es sein:

Ich brauche die Summe der Spalte AB2 BIS AB999. Wenn in der Spalte C2 bis C999 aber das Wort OLIO oder PAC steht, sollte die Summe durch 10 dividiert werden. Die summe sollte auch trotz #NV in der Spalte AB gemacht werden.

dankeschön schon im voraus

Jonas0806
23.08.2017, 14:26
Hallo,

ohne Hilffspalte fällt mir jetzt nur diese Matrixformel ein

{=SUMME((C2:C999="OLIO")*WENNFEHLER(AB2:AB999;0))}

Achtung Matrixformel! Die {} nicht mit eingeben, stattdessen die Formel mit Strg+Shift+Enter abschließen.

Hatte vergessen "PAC" zu berücksichtigen

{=SUMME(((C2:C999="OLIO")+(C2:C999="PAC"))*WENNFEHLER(AB2:AB999;0))}

ciappal
23.08.2017, 14:32
Hallo Jonas, vielen dank für die antwort.
sorry sorry, ich habe mich etwas falsch ausgedrückt, kannst du es dir evtl nochmal anschauen?

so war es gemeint:


Ich brauche die Summe der Spalte AB2 BIS AB999. Wenn in der Spalte C2 bis C999 aber das Wort OLIO oder PAC steht, sollte die Summe durch 10 dividiert werden. Die summe sollte auch trotz #NV in der Spalte AB gemacht werden.


das mit dem PAC und OLIO habe ich bereits für eine andere tabelle gelöst (siehe unten) aber bekomme die summe der Spalten AB2 BIS AB999 nicht zusammen

es könnte doch so irgendwie klappen oder? Dann wäre nur noch einzufügen dass #NV nicht berücksichtigt wird

=WENN(ODER(LINKS(c2;3)="PAC";LINKS(c2;3)="OLIO");AB2:999)

ciappal
23.08.2017, 16:56
Sorry für das Spamming, aber versuche es schon den ganzen nachmittag...

bin jetzt so weit gekommen, aber irgendetwas stimmt noch immer nicht, hat jemand eine idee?

=WENN(ODER(LINKS(C2;3)="PAC";LINKS(C2;4)="OLIO";(AB2+AB3:1000)/10);(AB2+AB3:1000;"<>#NV))

danke nocheinmal

Jonas0806
23.08.2017, 18:16
Hallo,

ich habe doch hier (http://www.ms-office-forum.net/forum/showpost.php?p=1825535&postcount=2) bereits eine Lösung gepostet.

Ausserdem änderst Du deine Anforderungen, steht in der jeweiligen Zelle nun "PAC" oder "OLIO", oder sind diese Worte nur in den Zellen enthalten? Das ist ein Unterschied, ich frage wegen deiner Formel LINKS(...)...

Bitte lade eine Beispieldatei hoch und trage dein Wunschergebnis händisch ein, bevor wir hier noch 10x hin und her schreiben. Beschreibe deine genauen Anforderungen und achte darauf, dass deine Beispieldatei exakt den selben Aufbau hat, wie dein Original.

Und noch etwas. Wir sind nicht rund um die Uhr an unseren Rechnern um dir zu helfen, Du möchtest es also bitte verzeihen, wenn Du mal über 2,5h keine Antwort bekommst...:rolleyes:

ciappal
23.08.2017, 19:42
Ich hab mich anfangs aus versehen nicht klar ausgedrückt, aber hey ich hab mich ja entschuldigt... was soll ich denn noch...

Ich brauche die Summe aus Spalte AB von Zeile 2 bis Zeile 999! Aber, alle Gewichte von Artikelnummern welche mit PAC und mit OLIO beginnen müssen durch 10 dividiert werden. Außerdem soll die Spalte trotz #NV summiert werden


vielen dank nochmal

Jonas0806
23.08.2017, 19:48
Hallo,

{=SUMME(WENN(((LINKS(C2:C999;4)="OLIO")+(LINKS(C2:C999;3)="PAC"));WENNFEHLER(AB2:AB999;0)/10;WENNFEHLER(AB2:AB999;0)))}

BoskoBiati
23.08.2017, 20:01
Hi,

oder so:

{=SUMME(WENNFEHLER(AB2:AB30;0)/(1+(ISTZAHL(SUCHEN("PAC";C2:C30))+ISTZAHL(SUCHEN("OLI";C2:C30))>0)*9))}

ciappal
23.08.2017, 20:37
vielen Dank für die Antworten, aber wenn ich die Formel in die Zelle AE4 eintrage, kommt bei der ersten lösung 0,777 und bei der zweiten 0,8555 heraus..

Mache ich etwas falsch? :boah:

BoskoBiati
23.08.2017, 20:39
Hi,

anhand Deines Beispiels:

<table border='1' cellspacing='0' cellpadding='2' valign='middle' colspan='3' style='font-family:Calibri; color:#000000; background-color:#FFFFFF; font-size:11px; font-weight:normal; font-style:normal; '><colgroup><col width='28pt'><col width='87,75pt'><col width='60pt'></colgroup><tr style='background-color:#FAFAFA'><td align='middle' colspan='3'>Arbeitsblatt mit dem Namen 'Tabelle1'</td></tr><tr style='background-color:#cacaca'><td>*</td><td align='middle'>AD</td><td align='middle'>AE</td></tr><tr><td style='background-color:#cacaca' align='middle'>4</td><td align='left' >Summe Spalte AB</td><td align='right' >8,7187</td></tr><tr><td style='background-color:#cacaca' align='middle'>5</td><td align='right' >*</td><td align='right' style='font-family:Arial Unicode MS; font-size:10px; ' >8,7187</td></tr><tr><td style='background-color:#cacaca' align='middle'>6</td><td align='right' >*</td><td align='right' style='font-family:Arial Unicode MS; color:#007700; font-size:10px; ' >8,7187</td></tr></table><br><table border='3' cellspacing='0' cellpadding='2' valign='middle' colspan='2' style='table-layout:auto; color:#000000; background-color:#FFFFFF; font-family:Calibri; font-size:10px;'><colgroup><col width='40pt'><col></colgroup><tr style='background-color:#eeaaaa'><td>Zelle</td><td>Formel</td></tr><tr><td>AE5</td><td><Span style='color:#222222'>{=SUMME</Span><Span style='color:#0000DD'>(WENNFEHLER</Span><Span style='color:#222222'>(AB2:AB30;0)</Span><Span style='color:#0000DD'>/</Span><Span style='color:#222222'>(1+</Span><Span style='color:#0000DD'>(ISTZAHL</Span><Span style='color:#222222'>(SUCHEN</Span><Span style='color:#0000DD'>("PAC";C2:C30)</Span><Span style='color:#222222'>)</Span><Span style='color:#0000DD'>+ISTZAHL</Span><Span style='color:#222222'>(SUCHEN</Span><Span style='color:#0000DD'>("OLI";C2:C30)</Span><Span style='color:#222222'>)</Span><Span style='color:#0000DD'>>0)</Span><Span style='color:#222222'>*9)</Span><Span style='color:#0000DD'>)</Span><Span style='color:#222222'>}</Span></td></tr><tr><td>AE6</td><td><Span style='color:#222222'>{=SUMME</Span><Span style='color:#0000DD'>(WENN</Span><Span style='color:#222222'>(</Span><Span style='color:#0000DD'>(</Span><Span style='color:#222222'>(LINKS</Span><Span style='color:#0000DD'>(C2:C999;4)</Span><Span style='color:#222222'>="OLIO")</Span><Span style='color:#0000DD'>+</Span><Span style='color:#222222'>(LINKS</Span><Span style='color:#0000DD'>(C2:C999;3)</Span><Span style='color:#222222'>="PAC")</Span><Span style='color:#0000DD'>)</Span><Span style='color:#222222'>;WENNFEHLER</Span><Span style='color:#0000DD'>(AB2:AB999;0)</Span><Span style='color:#222222'>/10;WENNFEHLER</Span><Span style='color:#0000DD'>(AB2:AB999;0)</Span><Span style='color:#222222'>)</Span><Span style='color:#0000DD'>)</Span><Span style='color:#222222'>}</Span></td></tr></table><table style='font-family:Arial; font-size:8pt; background-color:#FFFFFF'><tr><td style='font-weight:bold'>Achtung, Matrixformel enthalten!</td></tr><tr><td><span>Die geschweiften Klammern{} werden </span><span style='text-decoration:underline'>nicht</span><span> eingegeben.</span></td></tr><tr><td><span>Verlassen Sie den Zelleneditor mit </span><span style='font-weight:bold; color:#FF0000'>Strg+Shift + Enter</span><span>, statt Enter alleine.</span></td></tr></table><table style='font-family:Arial; font-size:7pt'><tr><td style='color:#333333'>Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg</td></tr></table>

ciappal
23.08.2017, 21:41
Habs nicht verstanden dass es eine matrixformel ist.

Jetzt läufts perfekt, vielen vielen Dank