PDA

Vollständige Version anzeigen : Sverweis mag nicht


Joao
21.08.2017, 15:30
Hallo Gemeinde,

ich wollte gerade auf die schneller meine Tabelle ergänzen mit ein sverweis, doch es mag nicht Funktionieren.

Suchkriterium: ab Zelle F2
Matrix: AA2:AB9999
Spalten Index: 2
Ergebnis ab Zelle M2: #NV

Formel in Zelle M2: =SVERWEIS(F2;$AA$2:$AB$9999;2;FALSCH)

Habe ich hier ein Denkfehler?

steve1da
21.08.2017, 15:40
Hola,

die grünen Dreiecke vor den "Zahlen" in Spalte F sind recht interessant.

Gruß,
steve1da

losgehts
21.08.2017, 15:40
Hallo,

in Spalte F sind diene Zahlen als Text gespeichert, daran liegt es. Ist das Absicht?

Du kannst sie in echte Zahlen umwandeln, indem du eine 1 in eine nichtbenutzte Zelle schreibst, diese Zelle markierst, Strg + C drückst jetzt markierst du Spalte F und machst einen Rechtslkick => Inhalte einfügen => Multiplizieren.

klappt's?
Grüße, Ulrich

EarlFred
21.08.2017, 15:40
Hallo,

die zu suchenden Werte in Spalte F sind TEXT (sieht man am grünen Dreieck...), die zu durchsuchenden Werte sind ZAHLEN. Sverweis nimmt das sehr genau.

Entweder machst Du aus den Texten in Spalte F Zahlen (NICHT das Format ändern, sondern den Wert -> z. B. mit 1 multiplizieren) oder Du regelst das (etwas unelegant) in der Formel:
=SVERWEIS(1*F2;$AA$2:$AB$23;2;FALSCH)

Grüße
EarlFred