PDA

Vollständige Version anzeigen : Summenprodukt


The Grey
18.08.2017, 08:20
Hallo Forum,

uff... die Registrierung hat es in sich, aber ich habe es doch geschafft. ;)

So, ich steige gleich mit einer Frage ein, weil ich nicht weiter komme.

Aufgabe:
1. 2 Arbeitsblätter mit Namen "1" und "2"
2. Prüfung 1 - Ist Monat "Januar" - Spalte R
3. Prüfung 2 - Ist Name "T679" - Spalte D
4. Wenn 2 und 3 Wahr sind, dann Summe über Spalte J

Aufgebaut habe ich auf folgender Grundlage:
http://www.excelformeln.de/formeln.html?welcher=342

Habe die o.g. Formel in 3 Varianten ausprobiert:
V1. =SUMME((T(INDIREKT(SPALTE(A:B)&"!R"&ZEILE(15:100)))="Januar")*(T(INDIREKT(SPALTE(A:B)&"!D"&ZEILE(15:100)))="T679")*(N(INDIREKT(SPALTE(A:B)&"!J"&ZEILE(15:100)))))

V2.=SUMME((T(INDIREKT(""&SPALTE(A:B)&"!R"&ZEILE(15:100)))="Januar")*(T(INDIREKT(""&SPALTE(A:B)&"!D"&ZEILE(15:100)))="T679")*(N(INDIREKT(""&SPALTE(A:B)&"!J"&ZEILE(15:100)))))

V3. =SUMME((T(INDIREKT(""&{"1"."2"}&"!R"&ZEILE(15:100)))="Januar")*(T(INDIREKT(""&{"1"."2"}&"!D"&ZEILE(15:100)))="T679")*(N(INDIREKT(""&{"1"."2"}&"!J"&ZEILE(15:100)))))

Für meine Anwendung funktioniert zZ. nur V3 (es prüft beide Blätter, während die ersten Formeln nur Blatt "1" prüfen) und auch das nicht perfekt.
Problem ist, die Formel fragt nur ZEILE 15 bei den Blättern ab und hört dann auf.

Hat einer eine Idee wieso?

Leere Zeilen kann ich soweit ausschließen, weil ich das bereits im Rahmen des Ausschlussverfahren getestet habe, es hätte mir min. ZEILE 16 dazu addieren müssen, weil die Rahmenbedingungen zur ZEILE 15 identisch waren.

P.S. ich fange auch in Zeile 15 an, weil ich gemerkt habe, dass die Formel Probleme damit hat, wenn zuvor in Spalten Formeln/Werte hinterlegt sind, die für diese Formel "keinen Sinn" machen. "Nach hinten" ist alles leer, d.h. nur leere Zeilen.

Danke

steve1da
18.08.2017, 08:26
Hola,

die Formeln geben alle das gleiche Ergebnis aus - wenn man sie mit Strg-Shift-Enter abschließt.

Gruß,
steve1da

The Grey
18.08.2017, 08:32
:upps: :upps: :upps: :upps: :upps: :upps:

DANKE!

Btw. Strg-Shift-Enter - wann muss ich dies Nutzen, bzw. was ist die Idee dahinter?

steve1da
18.08.2017, 08:47
Hola,

dabei handelt es sich um eine Matrixformel:

http://www.online-excel.de/excel/singsel.php?f=26

Erkennbar an den {} um die Formel, die durch Strg-Shift-Enter erzeugt werden.

Gruß,
steve1da

Oge
18.08.2017, 10:45
Hallo,

Achtung! In dem Link hat Peter eine falsche/ungünstige Notierung in den Bereichen "Formeln der Tabelle".
C3 : {=Tabelle1!B2:B4-Tabelle2!D6:D8}
C4 : {=Tabelle1!B2:B4-Tabelle2!D6:D8}
C5 : {=Tabelle1!B2:B4-Tabelle2!D6:D8}
suggeriert, dass die Formel in jede Zelle geschrieben steht und nicht, wie im Text richtig beschrieben, nur einmalig eingetragen wird. Hier wäre
C3:C5 : {=Tabelle1!B2:B4-Tabelle2!D6:D8}
wohl günstiger.