PDA

Vollständige Version anzeigen : "Summe" und "Links" mit variabler Textlänge


Killing Joke
28.09.2016, 11:25
Hallo,

ich hoffe Ihr könnt mir wieder bei meinem Problem helfen.
Ich habe eine Tabelle in der folgendes steht:
Spalte A = Einbauort ('1-1; '1-2; '1-3; '1-4 bis '10-1; '10-2; '10-3; '10-4) [' nur, weil es sonst als Datum ausgegeben wird]
Spalte B = Art (Matte; Stab)
Spalte C = Gewichte

Nun möchte ich eine Summe von zum Beispiel allen "10"ern (alle die 10-1, 10-2, 10-2, etc.) haben die in Spalte B ein "Stab" stehen haben.
Ich habe es mit "Summewenns" probiert, weiß aber nicht, wie ich das Problem "Links" mit manchmal einer Zahl und manchmal zwei Zahlen (oder eigentlich sind es Texte) lösen kann.

Kann mir da jemand einen Tipp geben?

steve1da
28.09.2016, 11:26
Hola,

eine kleine Beispieldatei wäre hilfreich ;-)

Gruß,
steve1da

Killing Joke
28.09.2016, 11:36
Selbstverständlich.
Wollte ich eigentlich schon angehängt haben, hatte es nur vergessen.

Danke für den Hinweis.

steve1da
28.09.2016, 11:44
Hola,

wenn der gesuchte Wert in F1 steht:

=SUMMENPRODUKT((LINKS(A1:A55;LÄNGE(F1))=""&F1&"")*(B1:B55="stabstahl"))

Gruß,
steve1da

Killing Joke
29.09.2016, 08:16
Moin steve1da,

danke für die Formel.
Bei deiner Formel wird aber "nur" die Anzahl der Einträge gezählt und nicht die Summe der "Gewichte" zusammenaddiert.
Kannst du mir da auch helfen?

Schöne Grüße

steve1da
29.09.2016, 08:18
Hola,

sorry, vergessen ;-)

=SUMMENPRODUKT((LINKS(A1:A55;LÄNGE(F1))=""&F1&"")*(B1:B55="stabstahl")*(C1:C55))

Gruß,
steve1da