PDA

Vollständige Version anzeigen : Wert in jede x. Zelle schreiben


tneumer
27.09.2016, 14:01
Hallo,

ich habe folgendes Problem: Ich habe in einer Spalte A Zahlen in aufsteigender Rangfolge von 1 bis 40. In spalte B möchte ich nun in jeder
x. Zelle den Wert 1 ausgeben. Der Wert x kommt aus einer Zelle (bspw. D1) und soll dynamisch veränderbar sein.
Mit welcher Formel kann ich in Spalte B die Werte setzen?

Beispiel:
D1 hat den Wert 2: Dann soll in B1, B3, B5,... 1 erscheinen
D1 hat den Wert 3: Dann soll in B1, B4, B7,... 1 erscheinen

Gruß

steve1da
27.09.2016, 14:11
Hola,

=WENN(REST(ZEILE();$D$1)=1;"x";"")

Gruß,
steve1da

Frank Furter
27.09.2016, 15:14
hallo, ich habe das so verstanden..:

=WENN($D$1=1;1;WENN(REST(ZEILE(A1);$D$1)=1;1;""))