PDA

Vollständige Version anzeigen : SVerweis nimmt nicht die richtigen Daten


grazioli
09.07.2015, 08:48
Ich bin daran, in einem Datenblatt (Einkauf) die Berechnungen zu erweitern.

Die Daten werden mit SVerweis aus einem weiteren Datenblatt (Verweistabelle) gezogen.

Bei Produkteserie kann ich 125 oder 150 eingeben und bei Spalte F muss ich noch die Gleise angeben, danach sollte es mir von der Verweistabelle den richtigen Preis aus der richtigen Spalte/Zeile in der Spalte M / ab Zeile 5 richtig berechnen.

Ausgewählt ist jetzt Produkteserie 150, aber es wird in den Zeilen 5 + 6 Daten aus der Produkteserie 125 berechnet.

Bedanke mich für Eure Hilfe

<b>Einkauf</b><br /><br /><table border="1" cellspacing="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:38px;" /><col style="width:33px;" /><col style="width:68px;" /><col style="width:65px;" /><col style="width:42px;" /><col style="width:61px;" /><col style="width:33px;" /><col style="width:61px;" /><col style="width:33px;" /><col style="width:82px;" /><col style="width:33px;" /><col style="width:90px;" /><col style="width:90px;" /><col style="width:90px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td><td >G</td><td >H</td><td >I</td><td >J</td><td >K</td><td >L</td><td >M</td><td >N</td><td >O</td></tr><tr style="height:28px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td colspan="3" style="font-size:11pt; ">&nbsp;</td><td colspan="2" style="font-size:13pt; ">&nbsp;</td><td style="font-size:11pt; ">&nbsp;</td><td colspan="5" style="font-weight:bold; font-size:13pt; text-align:right; ">Produkteserie</td><td style="color:#ffffff; font-size:12pt; text-align:center; ">2</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:21px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Pos. Bezeichnung</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">St&uuml;ck</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Breite in mm</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">H&ouml;he in mm</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">1= eingleisig, 2= zweigleisig, &nbsp;<br />3= dreigleisig, 4= viergleisig</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Fl&auml;che in m² je St&uuml;ck</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Beweglich</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Gesamtbreite Bewegliche Teile</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Fest</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Gesamtbreite Festteile</td><td rowspan="2" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Felder gesamt</td><td colspan="3" style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Kit-Preise</td></tr><tr style="height:227px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Kit-Preis / St&uuml;ck</td><td style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Kit-Preis / gesamt</td><td style="background-color:#ccffcc; font-size:12pt; text-align:center; ">Preis je m² / St&uuml;ck</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="background-color:#dce6f1; text-align:right; ">1</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#ffff66; text-align:right; ">1.0</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">500</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#ffff66; text-align:right; ">500</td><td style="background-color:#ffff66; text-align:center; ">2</td><td style="background-color:#ffff66; text-align:right; ">40 Fr</td><td style="background-color:#ffff66; text-align:right; ">40 Fr</td><td style="background-color:#ffff66; text-align:right; ">40 Fr</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="background-color:#dce6f1; text-align:right; ">1</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:center; ">2</td><td style="background-color:#ffff66; text-align:right; ">1.0</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">500</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#ffff66; text-align:right; ">500</td><td style="background-color:#ffff66; text-align:center; ">2</td><td style="background-color:#ffff66; text-align:right; ">80 Fr</td><td style="background-color:#ffff66; text-align:right; ">80 Fr</td><td style="background-color:#ffff66; text-align:right; ">80 Fr</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td style="background-color:#dce6f1; text-align:right; ">1</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:center; ">3</td><td style="background-color:#ffff66; text-align:right; ">1.0</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">500</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#ffff66; text-align:right; ">500</td><td style="background-color:#ffff66; text-align:center; ">2</td><td style="background-color:#ffff66; text-align:right; ">1'600 Fr</td><td style="background-color:#ffff66; text-align:right; ">1'600 Fr</td><td style="background-color:#ffff66; text-align:right; ">1'600 Fr</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td style="background-color:#dce6f1; text-align:right; ">1</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:right; ">1'000</td><td style="background-color:#dce6f1; text-align:center; ">4</td><td style="background-color:#ffff66; text-align:right; ">1.0</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#dce6f1; text-align:right; ">500</td><td style="background-color:#dce6f1; text-align:center; ">1</td><td style="background-color:#ffff66; text-align:right; ">500</td><td style="background-color:#ffff66; text-align:center; ">2</td><td style="background-color:#ffff66; text-align:right; ">3'200 Fr</td><td style="background-color:#ffff66; text-align:right; ">3'200 Fr</td><td style="background-color:#ffff66; text-align:right; ">3'200 Fr</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >G5</td><td >=WENN(D5*E5=0;"";D5*E5/10^6)</td></tr><tr><td >K5</td><td >=WENN(<span style=' color:008000; '>ODER(D5="";I5="")</span>;"";D5-I5)</td></tr><tr><td >L5</td><td >=WENN(H5+J5=0;"";H5+J5)</td></tr><tr><td >M5</td><td >=WENN(<span style=' color:008000; '>ODER(B5="";F5="";H5+J5=0)</span>;"";<span style=' color:008000; '><span style=' color:#0000ff; '>RUNDEN((D5+E5)</span>*2/1000*<span style=' color:#0000ff; '>WENN(<span style=' color:#ff0000; '>ODER($M$2*F5=1;$M$2*F5=2;$M$2*F5=3;$M$2*F5=4)</span>;<span style=' color:#ff0000; '>SVERWEIS(F5;Verweistabellen!$B$9:$F$13;2)</span>;<span style=' color:#ff0000; '>SVERWEIS(F5;Verweistabellen!$B$9:$F$13;4)</span>)</span>+I5/1000*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$34;Verweistabellen!$D$34)</span>+H5*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$35;Verweistabellen!$D$35)</span>+J5*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$40;Verweistabellen!$D$40)</span>;0)</span>)</td></tr><tr><td >N5</td><td >=WENN(<span style=' color:008000; '>ODER(B5="";M5="")</span>;"";<span style=' color:008000; '>RUNDEN(M5*C5;0)</span>)</td></tr><tr><td >O5</td><td >=WENN(<span style=' color:008000; '>ODER(B5="";M5="")</span>;"";<span style=' color:008000; '>RUNDEN(M5/G5;0)</span>)</td></tr><tr><td >G6</td><td >=WENN(D6*E6=0;"";D6*E6/10^6)</td></tr><tr><td >K6</td><td >=WENN(<span style=' color:008000; '>ODER(D6="";I6="")</span>;"";D6-I6)</td></tr><tr><td >L6</td><td >=WENN(H6+J6=0;"";H6+J6)</td></tr><tr><td >M6</td><td >=WENN(<span style=' color:008000; '>ODER(B6="";F6="";H6+J6=0)</span>;"";<span style=' color:008000; '><span style=' color:#0000ff; '>RUNDEN((D6+E6)</span>*2/1000*<span style=' color:#0000ff; '>WENN(<span style=' color:#ff0000; '>ODER($M$2*F6=1;$M$2*F6=2;$M$2*F6=3;$M$2*F6=4)</span>;<span style=' color:#ff0000; '>SVERWEIS(F6;Verweistabellen!$B$9:$F$13;2)</span>;<span style=' color:#ff0000; '>SVERWEIS(F6;Verweistabellen!$B$9:$F$13;4)</span>)</span>+I6/1000*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$34;Verweistabellen!$D$34)</span>+H6*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$35;Verweistabellen!$D$35)</span>+J6*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$40;Verweistabellen!$D$40)</span>;0)</span>)</td></tr><tr><td >N6</td><td >=WENN(<span style=' color:008000; '>ODER(B6="";M6="")</span>;"";<span style=' color:008000; '>RUNDEN(M6*C6;0)</span>)</td></tr><tr><td >O6</td><td >=WENN(<span style=' color:008000; '>ODER(B6="";M6="")</span>;"";<span style=' color:008000; '>RUNDEN(M6/G6;0)</span>)</td></tr><tr><td >G7</td><td >=WENN(D7*E7=0;"";D7*E7/10^6)</td></tr><tr><td >K7</td><td >=WENN(<span style=' color:008000; '>ODER(D7="";I7="")</span>;"";D7-I7)</td></tr><tr><td >L7</td><td >=WENN(H7+J7=0;"";H7+J7)</td></tr><tr><td >M7</td><td >=WENN(<span style=' color:008000; '>ODER(B7="";F7="";H7+J7=0)</span>;"";<span style=' color:008000; '><span style=' color:#0000ff; '>RUNDEN((D7+E7)</span>*2/1000*<span style=' color:#0000ff; '>WENN(<span style=' color:#ff0000; '>ODER($M$2*F7=1;$M$2*F7=2;$M$2*F7=3;$M$2*F7=4)</span>;<span style=' color:#ff0000; '>SVERWEIS(F7;Verweistabellen!$B$9:$F$13;2)</span>;<span style=' color:#ff0000; '>SVERWEIS(F7;Verweistabellen!$B$9:$F$13;4)</span>)</span>+I7/1000*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$34;Verweistabellen!$D$34)</span>+H7*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$35;Verweistabellen!$D$35)</span>+J7*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$40;Verweistabellen!$D$40)</span>;0)</span>)</td></tr><tr><td >N7</td><td >=WENN(<span style=' color:008000; '>ODER(B7="";M7="")</span>;"";<span style=' color:008000; '>RUNDEN(M7*C7;0)</span>)</td></tr><tr><td >O7</td><td >=WENN(<span style=' color:008000; '>ODER(B7="";M7="")</span>;"";<span style=' color:008000; '>RUNDEN(M7/G7;0)</span>)</td></tr><tr><td >G8</td><td >=WENN(D8*E8=0;"";D8*E8/10^6)</td></tr><tr><td >K8</td><td >=WENN(<span style=' color:008000; '>ODER(D8="";I8="")</span>;"";D8-I8)</td></tr><tr><td >L8</td><td >=WENN(H8+J8=0;"";H8+J8)</td></tr><tr><td >M8</td><td >=WENN(<span style=' color:008000; '>ODER(B8="";F8="";H8+J8=0)</span>;"";<span style=' color:008000; '><span style=' color:#0000ff; '>RUNDEN((D8+E8)</span>*2/1000*<span style=' color:#0000ff; '>WENN(<span style=' color:#ff0000; '>ODER($M$2*F8=1;$M$2*F8=2;$M$2*F8=3;$M$2*F8=4)</span>;<span style=' color:#ff0000; '>SVERWEIS(F8;Verweistabellen!$B$9:$F$13;2)</span>;<span style=' color:#ff0000; '>SVERWEIS(F8;Verweistabellen!$B$9:$F$13;4)</span>)</span>+I8/1000*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$34;Verweistabellen!$D$34)</span>+H8*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$35;Verweistabellen!$D$35)</span>+J8*2*<span style=' color:#0000ff; '>WENN($M$2=1;Verweistabellen!$C$40;Verweistabellen!$D$40)</span>;0)</span>)</td></tr><tr><td >N8</td><td >=WENN(<span style=' color:008000; '>ODER(B8="";M8="")</span>;"";<span style=' color:008000; '>RUNDEN(M8*C8;0)</span>)</td></tr><tr><td >O8</td><td >=WENN(<span style=' color:008000; '>ODER(B8="";M8="")</span>;"";<span style=' color:008000; '>RUNDEN(M8/G8;0)</span>)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8 </a>





<b>Verweistabellen</b><br /><br /><table border="1" cellspacing="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:181px;" /><col style="width:82px;" /><col style="width:93px;" /><col style="width:133px;" /><col style="width:93px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td></tr><tr style="height:20px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td colspan="5" style="font-weight:bold; font-size:11pt; text-align:center; ">Preistabelle- Gleisigkeit (1, 2, 3 oder 4) und Fl&uuml;gelrahmen</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td >&nbsp;</td><td colspan="2" style="font-style:italic; text-align:center; ">Serie125:</td><td colspan="2" style="font-style:italic; text-align:center; ">Serie150:</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td style="font-style:italic; text-align:center; ">Anzahl der Gleise:</td><td style="font-style:italic; text-align:center; ">Meterpreis:</td><td style="font-style:italic; text-align:center; ">Gewicht je m:</td><td style="font-style:italic; text-align:center; ">Meterpreis:</td><td style="font-style:italic; text-align:center; ">Gewicht je m:</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td style="background-color:#92d050; text-align:right; ">1</td><td style="background-color:#92d050; text-align:right; ">10.00 Fr</td><td style="background-color:#92d050; ">&nbsp;</td><td style="background-color:#92d050; text-align:right; ">100.00 Fr</td><td style="background-color:#92d050; ">&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td style="text-align:right; ">2</td><td style="background-color:#dce6f1; text-align:right; ">20.00 Fr</td><td style="background-color:#dce6f1; ">&nbsp;</td><td style="background-color:#dce6f1; text-align:right; ">200.00 Fr</td><td style="background-color:#dce6f1; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td style="text-align:right; ">3</td><td style="background-color:#dce6f1; text-align:right; ">40.00 Fr</td><td style="background-color:#dce6f1; ">&nbsp;</td><td style="background-color:#dce6f1; text-align:right; ">400.00 Fr</td><td style="background-color:#dce6f1; ">&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >12</td><td style="background-color:#92d050; text-align:right; ">4</td><td style="background-color:#92d050; text-align:right; ">80.00 Fr</td><td style="background-color:#92d050; ">&nbsp;</td><td style="background-color:#92d050; text-align:right; ">800.00 Fr</td><td style="background-color:#92d050; ">&nbsp;</td></tr><tr style="height:21px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td style="text-align:right; ">Fl&uuml;gelrahmen</td><td style="background-color:#dce6f1; ">&nbsp;</td><td style="background-color:#dce6f1; ">&nbsp;</td><td style="background-color:#dce6f1; ">&nbsp;</td><td style="background-color:#dce6f1; ">&nbsp;</td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8 </a>

steve1da
09.07.2015, 09:21
Hola,

ich hab mir die Datei nicht angeschaut, aber setz den 4. Parameter im Sverweis mal auf FALSCH, bzw. 0.

Gruß,
steve1da

grazioli
10.07.2015, 11:41
Hallo,

nach dem ich den Paramter geändert habe, sieht es immer noch gleich aus!

Habe mal die ganze Berechnung auf das Wesentliche gekürzt:

<b>Einkauf</b><br /><br /><table border="1" cellspacing="0" style="font-family:Arial,Arial; font-size:10pt; background-color:#ffffff; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:90px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >M</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="background-color:#ffff66; text-align:right; ">40 Fr</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >M5</td><td >=WENN(<span style=' color:008000; '>ODER(B5="";F5="";H5+J5=0)</span>;"";<span style=' color:008000; '><span style=' color:#0000ff; '>RUNDEN((D5+E5)</span>*2/1000*<span style=' color:#0000ff; '>WENN(<span style=' color:#ff0000; '>ODER($M$2*F5=1;$M$2*F5=2;$M$2*F5=3;$M$2*F5=4)</span>;<span style=' color:#ff0000; '>SVERWEIS(F5;Verweistabellen!$B$9:$F$13;2)</span>;<span style=' color:#ff0000; '>SVERWEIS(F5;Verweistabellen!$B$9:$F$13;4)</span>)</span>;0)</span>)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8 </a>

Vieleicht hat jemand noch ein weitere Tipps.

Danke und Gruss
Grazioli

Superingo2
10.07.2015, 11:50
Hallo Grazioli,

den Hinweis von steve1da hast Du immer noch nicht beachtet. Denn ohne den 4. Parameter kann ein SVERWEIS auch nicht richtig funktionieren! Ändere dies, und Dein Problem wird gelöst sein.

Vieleicht hat jemand noch ein weitere Tipps.

Warum willst Du noch weitere Tips, wenn Du den Einen noch nicht einmal anwendest? Es wird die Lösung sein!

LG Ingo

Superingo2
10.07.2015, 11:59
Hallo Grazioli,

die parametererweiterte Formel sähe dann so aus:
=WENN(ODER(B5="";F5="";H5+J5=0);"";RUNDEN((D5+E5)*2/1000*WENN(ODER($M$2*F5=1;$M$2*F5=2;$M$2*F5=3;$M$2*F5=4);SVERWEIS(F5;Verweistabel len!$B$9:$F$13;2;0);SVERWEIS(F5;Verweistabellen!$B$9:$F$13;4;0));0))


Besser fände ich aber:
=WENN(ODER(B5="";F5="";H5+J5=0);"";RUNDEN((D5+E5)*2/1000*SVERWEIS(F5;Verweistabellen!$B$9:$F$13;WENN(ODER($M$2*F5=1;$M$2*F5=2;$M$2*F 5=3;$M$2*F5=4);2;4);0);0))


LG Ingo

Superingo2
10.07.2015, 12:22
Hallo Grazioli,

irgendwie ist da aber noch mehr schief.
Ich gehe mal davon aus, dass man in M2 die Produktserie hereinschreiben muss, also 125 oder 150.
Dann würde ich die Formel so aufbauen:

=WENN(ODER(B5="";F5="";H5+J5=0);"";RUNDEN((D5+E5)*2/1000*SVERWEIS(F5;Verweistabellen!$B$9:$F$13;WENN($M$2=1;2;4);0);0))

LG Ingo

grazioli
10.07.2015, 14:13
Hallo,

ich habe den 4. Parameter so gesetzt!

=WENN(ODER(B5="";F5="";H5+J5=0);"";RUNDEN((D5+E5)*2/1000*WENN(ODER($M$2*F5=1;$M$2*F5=2;$M$2*F5=3;$M$2*F5=4);SVERWEIS(F5;Verweistabel len!$B$9:$F$13;0);SVERWEIS(F5;Verweistabellen!$B$9:$F$13;0));0))

Dies war Falsch!

Ich bedanke mich aber Superingo2 für die Hilfe, da es jetzt funktioniert.

Gruss Grazioli

Superingo2
10.07.2015, 14:19
Hallo Grazioli,

nun hast Du nur den 3. Parameter auf Null gesetzt! Das ist total falsch!
Einen 4. Parameter hast Du gar nicht erst, und diesen sollst Du mit "0" anlegen!

Aber schaue Dir mal meine neuen Vorschläge an.

LG Ingo

Superingo2
10.07.2015, 14:31
Hallo Grazioli,

der Teil:
ODER($M$2*F5=1;$M$2*F5=2;$M$2*F5=3;$M$2*F5=4)
ist total schief aufgebaut und bewirkt nur durch Zufall das Gewollte!
Denn eine WAHR erhälst Du nun immer, wenn in M2 das ERSTE ausgewählt ist, aber auch wenn in M2 das ZWEITE ausgewählt ist und in F5 eine 1 oder 2 steht (2*1=2, bzw. 2*2=4). Letzteres ist aber doch nicht von Dir gewünscht?
Daher nimm doch meine Formel aus #6.

LG Ingo