PDA

Vollständige Version anzeigen : Linien-Digramm - Zeitraum mit Lücken


Koop
21.07.2014, 22:45
Hi zusammen,
leider habe ich derzeit ein kleines Problem mit einem Diagramm, dass sich auch mit Google + Forensuche nicht so recht lösen lässt (vll auch, weil ich einfach nicht weiß, wie ich es kurz beschreiben soll :( )

Ich habe Daten, die aus einer Datenbank (also CSV Export) kommen, und zB wie folgt aussehen:
09.01.2014 75 74
10.01.2014 152 148
13.01.2014 132 121
14.01.2014 111 104
15.01.2014 93 88
16.01.2014 115 100
17.01.2014 85 80
20.01.2014 52 46
21.01.2014 104 105
Wie man hier sieht, gibt es zwischen den einzelnen Tagen Lücken (in dem Fall Wochenenden).

Nun möchte ich hier gerne ein Linien-Diagramm einfügen. Excel macht das auch recht gut über so einen Zeitraum.
Jedoch zeichnet es in diesem Fall die Lücken (z.B. zwischen 10.01. und dem 13.01.) einfach durch, also verbindet hier die 152 direkt mit der 132 - wobei der Zwischenwert eigentlich 0 wäre.

Ich habe hier schon versucht mit 'Datenquelle auswählen' -> 'Ausgeblendete und leere Zellen' zu arbeiten, jedoch ohne Erfolg.

Habt ihr hier vielleicht einen Vorschlag, wie man dies umsetzen kann, ohne hier manuell Daten mit 0-Werten einzufügen?

Danke schonmal :)

GMG-CC
22.07.2014, 03:11
Moin,

lege einen neuen Datenbereich mit allen Tagen an und verwende dann beispielsweise die Formel wie gezeigt ...


<b><em>Tabelle1</em></b><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "><colgroup><col style="font-weight:bold; width:40px;" /><col style="width:93px;" /><col style="width:97px;" /><col style="width:97px;" /><col style="width:97px;" /><col style="width:97px;" /><col style="width:97px;" /><col style="width:97px;" /></colgroup><tr style="background-color:#99CCFF; text-align:center; font-weight:bold; "><td>&nbsp;</td><td>A</td><td>B</td><td>C</td><td>D</td><td>E</td><td>F</td><td>G</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">1</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >09.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >75</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >74</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >09.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >75</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >74</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">2</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >10.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >152</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >148</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >10.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >152</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >148</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">3</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >13.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >132</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >121</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >11.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">4</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >14.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >111</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >104</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >12.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">5</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >15.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >93</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >88</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >13.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >132</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >121</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">6</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >16.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >115</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >100</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >14.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >111</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >104</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">7</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >17.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >85</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >80</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >15.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >93</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >88</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">8</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >20.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >52</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >46</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >16.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >115</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >100</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">9</td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >21.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >104</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >105</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >17.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >85</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >80</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">10</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >18.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">11</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >19.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >0</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">12</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >20.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >52</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >46</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">13</td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; ">&nbsp; </td><td style="color:#000000; background-color:#FFFFFF; text-align:left; " >21.01.2014</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >104</td><td style="color:#000000; background-color:#FFFFFF; text-align:right; " >105</td></tr></table><br/><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "><tr style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td colspan="4" > verwendete Formeln </td></tr><tr valign="top" style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td> Zelle </td><td> Formel </td><td> Bereich </td></tr><tr><td>F1 </td><td>=WENN(ISTNV(SVERWEIS(E1;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E1;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G1 </td><td>=WENN(ISTNV(SVERWEIS(E1;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E1;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F2 </td><td>=WENN(ISTNV(SVERWEIS(E2;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E2;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G2 </td><td>=WENN(ISTNV(SVERWEIS(E2;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E2;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F3 </td><td>=WENN(ISTNV(SVERWEIS(E3;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E3;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G3 </td><td>=WENN(ISTNV(SVERWEIS(E3;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E3;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F4 </td><td>=WENN(ISTNV(SVERWEIS(E4;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E4;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G4 </td><td>=WENN(ISTNV(SVERWEIS(E4;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E4;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F5 </td><td>=WENN(ISTNV(SVERWEIS(E5;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E5;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G5 </td><td>=WENN(ISTNV(SVERWEIS(E5;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E5;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F6 </td><td>=WENN(ISTNV(SVERWEIS(E6;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E6;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G6 </td><td>=WENN(ISTNV(SVERWEIS(E6;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E6;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F7 </td><td>=WENN(ISTNV(SVERWEIS(E7;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E7;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G7 </td><td>=WENN(ISTNV(SVERWEIS(E7;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E7;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F8 </td><td>=WENN(ISTNV(SVERWEIS(E8;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E8;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G8 </td><td>=WENN(ISTNV(SVERWEIS(E8;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E8;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F9 </td><td>=WENN(ISTNV(SVERWEIS(E9;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E9;$A$1:$C$9;2;FALSCH))</td><td></td></tr><tr><td>G9 </td><td>=WENN(ISTNV(SVERWEIS(E9;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E9;$A$1:$C$9;3;FALSCH))</td><td></td></tr><tr><td>F10 </td><td>=WENN(ISTNV(SVERWEIS(E10;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E10;$A$1:$C$9;2;FALSCH) )</td><td></td></tr><tr><td>G10 </td><td>=WENN(ISTNV(SVERWEIS(E10;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E10;$A$1:$C$9;3;FALSCH) )</td><td></td></tr><tr><td>F11 </td><td>=WENN(ISTNV(SVERWEIS(E11;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E11;$A$1:$C$9;2;FALSCH) )</td><td></td></tr><tr><td>G11 </td><td>=WENN(ISTNV(SVERWEIS(E11;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E11;$A$1:$C$9;3;FALSCH) )</td><td></td></tr><tr><td>F12 </td><td>=WENN(ISTNV(SVERWEIS(E12;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E12;$A$1:$C$9;2;FALSCH) )</td><td></td></tr><tr><td>G12 </td><td>=WENN(ISTNV(SVERWEIS(E12;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E12;$A$1:$C$9;3;FALSCH) )</td><td></td></tr><tr><td>F13 </td><td>=WENN(ISTNV(SVERWEIS(E13;$A$1:$C$9;2;FALSCH));0;SVERWEIS(E13;$A$1:$C$9;2;FALSCH) )</td><td></td></tr><tr><td>G13 </td><td>=WENN(ISTNV(SVERWEIS(E13;$A$1:$C$9;3;FALSCH));0;SVERWEIS(E13;$A$1:$C$9;3;FALSCH) )</td><td></td></tr></table>
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip Tabellendarstellung in Foren Version 7.3<br/>

Koop
22.07.2014, 14:52
Hat super geklappt! Vielen Dank für den Tip! :)