PDA

Vollständige Version anzeigen : Zeitstempel


Isabell
20.07.2014, 04:37
Hallo zusammen,
habe mal eine Frage. Möchte mit der WENN-Funktion einen Zeitstempen setzen wenn ein Eintrag erfolgt ist. Meine Formel ist:=WENN(ISTLEER(C3);"";JETZT()). Das funktioniert auch so weit. Wenn ich dann den Eintrag in der nächsten Zelle mache werden immer alle Zellen aktualisiert.
Aber die Einträge zuvor sollten nicht aktualisiert werden! Ist dies möglich?

aloys78
20.07.2014, 06:20
Hallo Isabell,
Aber die Einträge zuvor sollten nicht aktualisiert werden! Ist dies möglich?
Ja, zB durch folgendes Makro, das bei jeder Änderung in einer Zelle der Sp C ausgelöst wird.
Option Explicit

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Count > 1 Then Exit Sub
If Target.Column <> 3 Then Exit Sub
If Target <> "" Then
Target.Offset(0, -2) = Format(Date, "DDDD, DD. MMMM YYYY")
Target.Offset(0, -1) = Format(Time, "hh:mm:ss")
Else
Range(Target.Offset(0, -2), Target.Offset(0, -1)).ClearContents
End If
End Sub

Gruß
Aloys