PDA

Vollständige Version anzeigen : Abfrage: Markierung wenn innerhalb Gruppe identischem A-Wert unterschiedliche B-Werte


Lukas_92
19.07.2014, 12:03
Hallo zusammen!

Ich bin absolut kein Excel-Spezialist und stehe vor einer anscheinend sehr komplizierten Abfrage, konnte über Recherche leider noch keine Lösung finden :-( Vielleicht kann mir ja von euch jemand weiterhelfen, wäre super!
Also: Wenn in Spalte A ein Wert öfters vorkommt und in Spalte B innerhalb einer Gruppe mit gleichen A-Wert unterschiedliche B-Werte gegeben sind, dann soll Spalte B markiert werden, ansonsten soll keine Markierung erfolgen.

Spalte A Spalte B

Apfelbaum Hof 1
Apfelbaum Hof 1
Apfelbaum Hof 1
Apfelbaum Hof 1
Birnenbaum Hof 2
Birnenbaum Hof 2
Birnenbaum Hof 1
Birnenbaum Hof 2
Marillenbaum Hof 2
Marillenbaum Hof 2
Marillenbaum Hof 2
Marillenbaum Hof 2
Marillenbaum Hof 2

Also in Spalte A ist das Wort Birnenbaum identisch und innerhalb dieser Gruppe gibt es unterschiedliche B-Werte, was dann markiert werden soll.
Würde mich sehr freuen, wenn mir jemand weiterhelfen kann :-)

Danke und liebe Grüße

Mc Santa
19.07.2014, 12:31
Hallo,

ist die Tabelle nach Spalte A sortiert, wie im Beispiel?

Viele Grüße

Lukas_92
19.07.2014, 12:37
Hey!

Danke für deine Antwort.
Ja, ist nach Spalte A sortiert.

Danke und Liebe Grüße

ransi
19.07.2014, 12:37
HAllo

Das kannst du z.B. mit der bedingten Formatierung machen.
Schau es dir mal an:
<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Calibri,Arial; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:176px;" /><col style="width:80px;" /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td >Apfelbaum</td><td >Hof 1</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td >Apfelbaum</td><td >Hof 1</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td >Apfelbaum</td><td >Hof 1</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td >Apfelbaum</td><td >Hof 1</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td >Birnenbaum</td><td style="color:#ff0000; ">Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td >Birnenbaum</td><td style="color:#ff0000; ">Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >7</td><td >Birnenbaum</td><td style="color:#ff0000; ">Hof 1</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >8</td><td >Birnenbaum</td><td style="color:#ff0000; ">Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >9</td><td >Marillenbaum</td><td >Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >10</td><td >Marillenbaum</td><td >Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >11</td><td >Marillenbaum</td><td >Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >12</td><td >Marillenbaum</td><td >Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >13</td><td >Marillenbaum</td><td >Hof 2</td><td >&nbsp;</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >14</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#ff0000"><tr><td ><b>Bedingte Formatierungen der Tabelle</b></td></tr><tr><td ><table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial; font-size:10pt; padding-left:2pt; padding-right:2pt; "><tr><td >Zelle</td><td >Nr.: / Bedingung</td><td >Format</td></tr><tr><td >B1</td><td >1. / Formel ist =SUMMENPRODUKT(($A$1:$A$1000=A1)*($B$1:$B$1000=B1))&lt;&gt;Z&Auml;HLENWENN(A:A;A1)</td><td style="color:#ff0000; background-color:#000000; ">Abc</td></tr><tr><td >B2</td><td >1. / Formel ist =SUMMENPRODUKT(($A$1:$A$1000=A2)*($B$1:$B$1000=B2))&lt;&gt;Z&Auml;HLENWENN(A:A;A2)</td><td style="color:#ff0000; background-color:#000000; ">Abc</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>



ransi

Mc Santa
19.07.2014, 12:42
Hallo,

folgender Code funktioniert, solange deine Werte in Spalte A und Spalte B stehen, und nach Spalte A sortiert sind:
Im Anhang hast du das Makro bereits in einer Datei.
Sub werteMarkieren()

Dim rng As Range, saveR As Range
Dim mark As Boolean
With Worksheets("Tabelle1")
For Each rng In .Range(.Cells(1, 1), .Cells(Rows.Count, 1).End(xlUp))
If rng.Offset(1) <> rng Then
If mark Then
.Range(saveR, rng).Offset(, 1).Font.Color = 255
mark = False
End If
Set saveR = rng.Offset(1)
Else
If rng.Offset(, 1) <> rng.Offset(1, 1) Then
mark = True
End If
End If
Next rng
End With
End Sub

Hilft dir das?

Viele Grüße

Lukas_92
19.07.2014, 13:48
Hey,

das mit dem Makro hat super funktioniert :-D

Vielen Dank euch beiden!!!

Liebe Grüße