PDA

Vollständige Version anzeigen : Summenprodukt mit Prüfung und Zellwert


timberg0612
17.07.2014, 14:49
Hallo zusammen,

ich habe folgendes Problem:

Ich möchte 3 Arrays miteinander multiplizieren und anschließend aufsummieren. Da einige Werte Leerstrings sind (->"") habe ich die Formel wie folgt aufgestellt:

=SUMMENPRODUKT((E175:E182<>"")*(L175:L182<>"")*(N175:N182<>""))

leider multipliziert Excel nun nicht mehr die eigentlichen Zellwerte sondern jeweils 1 für true und gibt mir entsprechend die Anzahl der Tupel zurück auf die alle Bedingungen zutreffen anstatt deren Summenprodukt.

Wie erreiche ich es, dass wenn die Zellen <>"" sind, die eigentlichen Zellwerte für das Produkt verwendet werden?

Für jede Hilfe bin ich sehr dankbar.

http://s1.directupload.net/images/140717/7zfuisxa.png

Mc Santa
17.07.2014, 15:01
Hallo,

bei funktioniert folgendes:
=SUMMENPRODUKT("0"&E175:E182;"0"&L175:L182;"0"&N175:N182)

Hilft dir das?
VG

timberg0612
17.07.2014, 15:32
hm, komisch. Bei mir funktioniert die Lösung nicht.
Excel bildet ja dadurch erneut einen String, welcher bei der Berechnung nicht verwendet werden kann.
Trotzdem danke.

Ich habe bei mir folgende Lösung gefunden:

{=SUMMENPRODUKT(WENN(E175:E182<>"";E175:E182;0);WENN(L175:L182<>"";L175:L182;0);WENN(N175:N182<>"";N175:N182;0))}
-> Matrixformel

Mc Santa
17.07.2014, 15:41
Hallo,

es geht auch ganz ohne Prüfung:
<br/><b><em>Tabelle1</em></b><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "><colgroup><col style="font-weight:bold; width:40px;" /><col style="width:97px;" /><col style="width:97px;" /><col style="width:97px;" /></colgroup><tr style="background-color:#99CCFF; text-align:center; font-weight:bold; "><td>&nbsp;</td><td>A</td><td>B</td><td>C</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">1</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">9</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:left; ">&nbsp;</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">&nbsp;</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">2</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">&nbsp;</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:left; ">&nbsp;</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:left; ">&nbsp;</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">3</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">&nbsp;</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">3</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">3</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">4</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">&nbsp;</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:left; ">s</td><td style=" color:#000000; border-color:#000000; background-color:#FFFFFF ;; text-align:right; ">&nbsp;</td></tr></table><br/><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px;font-size:11pt; background-color:#ffffff; width:800px;padding-left:2pt; padding-right:2pt; "><tr style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td colspan="3" > verwendete Formeln </td><td> </td></tr><tr valign="top" style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td> Zelle </td><td> Formel</td><td> Bereich </td> <td>N/A</td></tr><tr><td>A1</td><td>=SUMMENPRODUKT(B1:B4;C1:C4)</td><td>&nbsp;</td><td>&nbsp;</td></tr><tr><td>B2:C2</td><td>=""</td><td>&nbsp;</td><td>&nbsp;</td></tr></table><table cellspacing="0" cellpadding="0"><tr style="text-align:left; font-weight:bold; " class="style21"><td style="text-align:left; font-size: xx-small" ><a href="http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip" >Excel-Inn.de</a></td></tr> <tr style="text-align:left; font-weight:bold; " class="style21"><td style="text-align:left; font-size: xx-small" ><a href='http://Hajo-Excel.de/tools.htm' >Hajo-Excel.de</a></td></tr><tr style="text-align:left; font-weight:bold;" ><td style="text-align:left; font-size: xx-small" >XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007</td></tr><tr style="text-align:left; font-weight:bold; " ><td style="text-align:left; font-size: xx-small" > Add-In-Version 18.01 einschl. 64 Bit</td></tr></table><br/>

Kannst du vielleicht deine Tabelle hochladen?

VG

EarlFred
17.07.2014, 15:43
Hallo?,

=SUMMENPRODUKT(E175:E182;L175:L182;N175:N182)

bzw. Rückgabewerte ="" in Formeln vermeiden.

Grüße
EarlFred

timberg0612
18.07.2014, 09:13
Ich hatte einen Fehler in der Fehler in der Formel in einer der Spalten:

Die Formel erstellte die Werte als Strings/Text "-1", somit funktionierte die Formel anfangs trotz Prüfung nicht.

So habt ihr recht. Ohne die Strings funktioniert die Formel auch ohne Prüfung
=SUMMENPRODUKT(E229:E390;L229:L390;N229:N390)

Danke für die schnellen Antworten!

Gruß
Tim