PDA

Vollständige Version anzeigen : #wert!


Emina!
14.07.2014, 13:54
Hallo

Wie kann ich die folgende Formel schreiben dass es mir in einigen Zellen kein #WERT! zeigt??

=WENN(A2<0;A2;"")*-1

Danke!

Mc Santa
14.07.2014, 13:58
Hallo,

Ab Excel 2007 so:
=WENNFEHLER(WENN(A2<0;A2;"")*-1;"")

Hilft dir das weiter?
VG

Emina!
14.07.2014, 14:02
Perfekt!

Vielen herzlichen Dank.

Gruss

EarlFred
14.07.2014, 14:04
Hallo,

und ab Excel 1789 so:
=WENN(A2<0;-A2;"")

Grüße
EarlFred

Emina!
14.07.2014, 14:56
OK, super! Danke euch, ich habe diese Formel für ein Makro benutzt, jedoch ist da noch ein Hacken.

Ich habe das Makro mit dem Aufzeichner erstellt, und habe die Formel einfach eingeschrieben und runtergezogen bis zur letzten Zeile. Jedoch wird die Tabelle nicht immer die selbe Anzahl an Zeilen haben.

Selection.AutoFill Destination:=Range("C2:C404")
Range("C2:C404").Select

Kann man es einrichten dass es sich immer der aktuellen Tabelle anpasst??

Anbei meine Tabelle zum leichteren Verständnis

Mc Santa
14.07.2014, 15:11
Hallo,

So würde es gehen:
Sub Makro1()
With Worksheets("Tabelle1")
.Range(.Cells(2, 3), .Cells(Rows.Count, 1).End(xlUp).Offset(, 2)).FormulaR1C1 = "=IF(RC[-2]<0,-RC[-2],"""")"
End With
End Sub

VG

Emina!
14.07.2014, 15:25
Irgendwie funktioniert es nicht...

Ich habe gar nicht daran gedacht, ein ganzes Makro erstellt und nicht Acht genommeen das es nicht immer die selbe Anzahl an Zeilen geben wird. Kann ich dir irgendwie mein Excel mit Makro senden dass bei dieser Form von Tabelle auch funktioniert, damit du es dir anschaust?

Leider funktioniert mein Makro nicht wenn ich ein paar mehr Zeilen habe :(, ich Dummkopf...