PDA

Vollständige Version anzeigen : Excel 2003 (Wenn Zahl gerade dann G - wenn ungerade dann U) ???


Angelina1990
12.07.2014, 07:02
hallo,

gibt es dafür eine Formel?

Wenn in BS 79 eine gerade Zahl steht dann schreibe in BS 80 ein G
Wenn in BS 79 eine ungerade Zahl steht dann schreibe in BS 80 ein U

Weiterhin möchte ich dann gerne die Formel nach rechts ausfüllen/übertragen

Also von BS79 bis CH79 analog dazu BS80 bis CH80

Danke vorab für Zeit und Mühe

LG
Angelina

hary
12.07.2014, 07:29
Moin
<br/><br/>
<b><em>Tabelle1</em></b><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "><colgroup><col style="font-weight:bold; width:40px;" /><col style="width:97px;" /><col style="width:97px;" /><col style="width:97px;" /><col style="width:97px;" /></colgroup><tr style="background-color:#99CCFF; text-align:center; font-weight:bold; "><td>&nbsp;</td><td>A</td><td>B</td><td>C</td><td>D</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">1</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:right; ">1</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:right; ">2</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:right; ">4</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:right; ">5</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">2</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">U</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">G</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">G</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">U</td></tr></table><br/><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px;font-size:11pt; background-color:#ffffff; width:800px;padding-left:2pt; padding-right:2pt; "><tr style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td colspan="3" > verwendete Formeln </td><td> </td></tr><tr valign="top" style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td> Zelle </td><td> Formel</td><td> Bereich </td><td>R1C1 für Add In</td></tr><tr><td>A2: D2</td><td>=WENN(REST(A1;2);"U";"G")</td><td>&nbsp;</td><td>&nbsp;=IF(MOD(R[-1]C,2),"U","G")</td></tr></table><br/><a href='http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip' >http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip</a><br/><a href='http://Hajo-Excel.de/tools.htm' >http://hajo-excel.de/tools.htm</a><br/>XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007<br/>Add-In-Version 14.02 einschl 64 Bit<br/>
gruss hary

aloys78
12.07.2014, 07:29
Hallo Angelina,

in BS 80
=WENN(ISTGERADE(BS$79)=WAHR;"G";"U")

und Formel nach rechts ziehen.

Gruß
Aloys

Hasso
12.07.2014, 08:05
Hallo Aloys,

ich glaube, dass es in Excel 2003 die Funktion ISTGERADE noch nicht gibt.

Angelina1990
12.07.2014, 09:23
@ Hasso, aloys78, hary

danke für eure Zeit.

Ich konnte mit dieser Formel das gewünschte erreichen.

=WENN(REST(BS79;2);"U";"G")


Damit ist meine Frage beantwortet.

Nochmals danke

LG
Angelina

aloys78
12.07.2014, 09:39
Hallo Hasso,

danke für den Hinweis; die Excel-Version hatte ich übersehen.

Soweit ich weiss, geht ISTGERADE auch in 2003, wenn das Add-in 'Analyse-Funktionen' installiert ist.

Gruß
Aloys