PDA

Vollständige Version anzeigen : Überschneidung von mehreren Zeiträumen feststellen


Steeeeven
11.07.2014, 06:52
Hallo zusammen,
habe folgendes Problem:

In Zellen M2:M13 habe ich Anfangszeiten und in N2:N13 die dazugehörigen Endzeiten.
Nun möchte ich überprüfen lassen / prüfen lassen, dass sich diese Zeiträume in irgendeiner Art überlappen. Ist dies der Fall, soll sich die Farbe der Zelle A20 in die Farbe rot ändern.

Kann ich das einfach ohne VBA realisieren?
Danke im Voraus
Gruß
Steffen

Mc Santa
11.07.2014, 07:24
Hallo,

das geht, wenn die Zeiten nach Spalte M aufsteigend sortiert sind.
Die Formel für die bedingte Formatierung heißt dann
=SUMME(N($M$3:$M$13<$N$2:$N$12))

Hilft dir das weiter?
VG

Steeeeven
11.07.2014, 07:42
Mhm,
nur bedingt, da die Zeiträume manchmal auf verstreut sein können, also erst ein später, dann ein früher,...
Wichtig ist nur, dass nie 2 Personen gleichzeitig an einem Tag abwesend sind...
Gruß
Steffen

Mc Santa
11.07.2014, 08:13
Hallo,

da ich spontan keine andere Idee habe, würde ich ein Makro schreiben, dass die Werte einliest, intern sortiert und dann die Methode von oben anwendet.

Ist das für dich eine Möglichkeit?
VG

Steeeeven
11.07.2014, 08:22
Oke,
werde es jetzt mal so versuchen, schön wäre es eben mit einer Formel gewesen, da flexibler...
Gruß
Steffen

EarlFred
11.07.2014, 08:22
Hallo Steffen,

probier mal:
{=SUMME((M2:M13<MTRANS(N2:N13))*(N2:N13>MTRANS(M2:M13)))-ZEILEN(M2:M13)}
oder
{=(SUMME((M2:M13<MTRANS(N2:N13))*(N2:N13>MTRANS(M2:M13)))-ZEILEN(M2:M13))>0}
Geschweifte Klammern nicht mit eingeben, sondern die Formeleingabe mit Strg+Shift+Enter abschließen (Matrixformel).

Ein Ergebnis > 0 bei Formel 1 oder die Rückgabe WAHR bei Formel 2 bedeuten, dass mindestens eine Zeitüberschneidung gefunden wurde.

Grüße
EarlFred

Steeeeven
11.07.2014, 08:38
Hallo,
ja ein bisschen geändert funktioniert das:

{=SUMME(--(M2:M12<MTRANS(M3:M13))*(N2:N12>MTRANS(M3:M13)))>0}


Danke & Gruß
Steffen

EarlFred
11.07.2014, 08:45
Hallo Steffen,

hab nicht aufgepasst: bei meinen Formeln wurden die ">" und "<" als HTML-Code interpretiert. Geänderte, nun richtige Darstellung im Beitrag 6.

Grüße
EarlFred

Steeeeven
11.07.2014, 08:53
funktioniert bei mir =)
sollte nicht?

EarlFred
11.07.2014, 13:15
Hallo Steffen,

ja ein bisschen geändert funktioniert das
ich erkenne keinen Änderungsbedarf an meiner Formel.

Wie auch immer Deine Änderung an der Formel aussieht (auch bei Dir wird die Darstellung verändert), vermute ich, dass sie nicht das gewünschte berechnet.

Grüße
EarlFred