PDA

Vollständige Version anzeigen : Wenn-formel


anni87
09.07.2014, 07:55
Hallo,

die folgende Wenn-Funktion wird nicht ausgeführt. Sie befindet sich in Zelle K9

=Wenn(K8="D1";Text"D1_in";Wenn(K8="D2";Text"D2_in";Wenn(K8="D3";Text"D3_in";Wenn(K8="D4";Text"D4_in";Wenn(K8="D5";Text"D5_in";Wenn(K8="D6";Text"D6_in";Wenn(K8="D7";Text"D7_in";Wenn(K8="D8";Text"D8_in";Wenn(K8="D9";Text"D9_in";Wenn(K8="D10";Text"D10_in";""))))))))))

geprüft werden soll, was in Zelle K8 steht
steht dort "D1" soll "D1_in" in Zelle L8 geschrieben werden... usw.

Kann mir jemand helfen?

In der Zelle steht die gesamte Formel und es wird nichts geprüft...

jenneck
09.07.2014, 08:03
Hallo ?,

welche Vorstellung hast Du denn, wie Dir ohne Beispielmappe geholfen werden soll?

Gruß Jens

hary
09.07.2014, 08:23
Moin
Recht dir evtl. auch nur pruefen ob Links "D"?
<br/><br/>
<b><em>Tabelle1</em></b><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "><colgroup><col style="font-weight:bold; width:40px;" /><col style="width:97px;" /></colgroup><tr style="background-color:#99CCFF; text-align:center; font-weight:bold; "><td>&nbsp;</td><td>K</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">8</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">D1</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">9</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">D1_in</td></tr></table><br/><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px;font-size:11pt; background-color:#ffffff; width:800px;padding-left:2pt; padding-right:2pt; "><tr style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td colspan="3" > verwendete Formeln </td><td> </td></tr><tr valign="top" style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td> Zelle </td><td> Formel</td><td> Bereich </td><td>R1C1 für Add In</td></tr><tr><td>K9</td><td>=WENN(LINKS(K8;1)="D";K8&amp;"_in";"")</td><td>&nbsp;</td><td>&nbsp;=IF(LEFT(R[-1]C,1)="D",R[-1]C&amp;"_in","")</td></tr></table><br/><a href='http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip' >http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip</a><br/><a href='http://Hajo-Excel.de/tools.htm' >http://hajo-excel.de/tools.htm</a><br/>XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007<br/>Add-In-Version 14.02 einschl 64 Bit<br/>
ansonsten nimm mal Text raus.
Wenn(K8="D1";"D1_in".....
gruss hary

anni87
09.07.2014, 08:37
Hallo Harry,

ich benötige leider auch die Ziffern hintern dem "D"...

hary
09.07.2014, 08:53
Moin
Geht bis 10.
<br/><br/>
<b><em>Tabelle1</em></b><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "><colgroup><col style="font-weight:bold; width:40px;" /><col style="width:97px;" /></colgroup><tr style="background-color:#99CCFF; text-align:center; font-weight:bold; "><td>&nbsp;</td><td>K</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">8</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">D10</td></tr><tr><td style="background-color:#99CCFF; text-align:center; font-weight:bold; ">9</td><td style="color:#000000; background-color:#FFFFFF ;; text-align:left; ">D10_in</td></tr></table><br/><table border="1" cellspacing="0" cellpadding="0" style="border-color:#000000; border-width: 1px;font-size:11pt; background-color:#ffffff; width:800px;padding-left:2pt; padding-right:2pt; "><tr style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td colspan="3" > verwendete Formeln </td><td> </td></tr><tr valign="top" style="background-color:#FFCC66; text-align:center; font-weight:bold; "><td> Zelle </td><td> Formel</td><td> Bereich </td><td>R1C1 für Add In</td></tr><tr><td>K9</td><td>=WENN(UND(LINKS(K8;1)="D";VERWEIS(9^9;1*RECHTS(K8;SPALTE(1:1)))&lt;11);K8&amp;"_in";"")</td><td>&nbsp;</td><td>&nbsp;=IF(AND(LEFT(R[-1]C,1)="D",LOOKUP(9^9,1*RIGHT(R[-1]C,COLUMN(R[-8])))&lt;11),R[-1]C&amp;"_in","")</td></tr></table><br/><a href='http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip' >http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip</a><br/><a href='http://Hajo-Excel.de/tools.htm' >http://hajo-excel.de/tools.htm</a><br/>XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007<br/>Add-In-Version 14.02 einschl 64 Bit<br/>
gruss hary

anni87
09.07.2014, 08:57
super danke...