PDA

Vollständige Version anzeigen : Logpunkte Temperatur vereinheitlichen


Mayden
07.07.2014, 14:01
Hallo zusammen,

mein Problem ist leider etwas schwer in eine Überschrift zu beschreiben deshalb versuche ich euch hier mal genau zu erklären was mein Problem ist.
(dazu am besten auch den Anhang betrachten)

Ich habe einen Temperaturlogger der mir die Temperatur eines Prüflings mitlogt.

Im Normalfall kommt eine wert von 17.34 raus (2 Ziffern vor und nach dem Punkt und eventull ein - davor)

Ab und zu jedoch hat der Logger anscheinend eine Macke und statt des Wertes logt er mir einen Wert von z. b. 695.000.000.000.005 (statt 6.95)
oder -204.999.999.999.995 (statt -2.04)

Habt ihr ne Idee wie ich das über einen Filter oder wie auch immer dementsprechend kürzen kann?
Es sind zu viele Werte sprich zu zeitaufwendig das von Hand zu machen.

Hoffe ich konnte euch erklären was ich genau meine.

Danke schonmal!

chris-kaiser
07.07.2014, 14:20
Hi,

wie kommen diese Werte in die Tabelle?
Import?,kopieren? oder ist das schon ein Logfile?

Das Problem ist das Excel . als Tausender-Trennzeichen sieht und nicht als Komma.
Sind jetzt einige "Nachkommastellen" wird das eben so dargestellt.

Mayden
07.07.2014, 14:26
Die Werte werden so wie sie sind von dem Logger in die Datei gepackt.

Kann man das trotzdem irgendwie umgehen?

chris-kaiser
07.07.2014, 14:33
Hi,

autsch...
wenn das jetzt auf einem speziellen Rechner lauft wo sonst nicht gearbeitet wird. Könnte in den Optionen bei Erweitert -> Trennzeichen vom Betriebssystem übernehmen, der Haken entfernt werden und . als Komma eingegeben werden oder gleich im Betriebssystem umstellen.

Aber das hilft Dir JETZT gerade nicht ^^, wenn du den Salat den du da hast umwandeln willst.....
Mal schauen vielleicht fällt mir da noch was ein.

Mayden
07.07.2014, 14:37
Der Logger läuft auf nem Laptop, sollte dort also für später kein Problem darstellen das zu ändern, aber wie du selbst gesagt hast bringt mir das aktuell nichts.

Habe hier 17 solcher Dateien und muss die gerade alle von Hand anpassen
(wurde immer schon so gemacht, mich kotzt das jetzt aber schon an und ich hab erst angefangen)

chris-kaiser
07.07.2014, 14:47
Hi,

füge in B2 folgende Formel ein

=WENN(ISTTEXT(A2);--WECHSELN(A2;".";",");LINKS(ABS(A2);3)*VORZEICHEN(A2)/100)

doppelklick auf dem Autoausfüllpunkt....

und passt es?

danach Spalte B kopieren und in Spalte A über Inhalte einfügen -> Werte die Daten ersetzen.

Mayden
07.07.2014, 15:13
Als ich deine Formel verwendet habe wurde bei mir FALSCH angezeigt,

habe nun selbst einmal rum probiert und folgendes gefunden bzw. denke das werde ich so nehmen.

Ich habe zuerst die . durch , ersetzt und dann folgende Formel verwendet;


=WENN(ODER(A2<-100;A2>100);(LINKS(A2;LÄNGE(A2)-12))/100;A2)

chris-kaiser
07.07.2014, 15:23
Hi,

durch das ersetzen könnte wieder was schief gehen ;)

hier mal die Datei ;)
da kommt kein Falsch.

Mayden
07.07.2014, 15:34
Ok, habs nochmal neu Probiert und es funktioniert einwandfrei :)

Danke dafür.

Mayden
08.07.2014, 08:12
Eine Frage hab ich noch, was muss ich in der Formel ändern, damit er den Wert rundet?

so das aus -344.999.999.999.999 dann -3,45 wird? Aktuell schneidet er ja die 9ner nur weg wodurch als Ergebnis -3,44 raus kommt.

Danke schonmal

chris-kaiser
08.07.2014, 08:28
Hi,

in B2

=WENN(ISTTEXT(A2);--WECHSELN(A2;".";",");RUNDEN(LINKS(ABS(A2);4)*VORZEICHEN(A2)/1000;2))

lg

Mayden
08.07.2014, 09:04
Wunderbar :top: