PDA

Vollständige Version anzeigen : Wenn Text in A45 dann in B45 das heutige Datum.


Lex8
04.07.2014, 15:24
Hi Leute,

sry aber ich bekomme das nicht hin, kann mir einer bitte nen denkanstoß geben?

Ich habe diese Formel verwendet:

=WENN(ISTTEXT(A45);"=heute()";"")

aber der schreibt mir =heute() rein. Ist ja logisch, aber wie kann ich dem sagen, dass dies eine Formel ist?

gruß und danke lex

aloys78
04.07.2014, 15:35
Halllo lex,
Wenn Text in A45 dann in B45 das heutige Datum.
Dann schreibe in B45
=WENN(ISTTEXT(A45);HEUTE();"")

Gruß
Aloys

hary
04.07.2014, 15:36
Moin
=WENN(ISTTEXT(A45);heute();"")
Heute veraendert sich aber morgen, aktuellisiert sich jeden tag
gruss hary

Lex8
04.07.2014, 15:41
ach mist, wie kann ich dann nur das datum einfügen, wenn ich A45 bearbeite?

geht das irgendwie?

gruß lex

EarlFred
04.07.2014, 15:52
Hallo lex,

kannst Du bitte klar und deutlich schreiben, wo das Problem liegt und was Du erreichen willst?
Mit Deinen hingeworfenen Satzbrocken kann keiner was anfangen.

Gib Dir doch Mühe - Du willst doch schließlich eine funktionierende Lösung!

Grüße
EarlFred

Lex8
04.07.2014, 16:16
Ok, sry

ich möchte in A1 zb. Alex reinschreiben, dann soll er mir das Heutige Datum in A2 schreiben. Dieses Datum soll aber morgen immer noch das heutige Datum sein.

ich hoffe so ists jetzt genau erklärt.

danke gruß lex

EarlFred
04.07.2014, 16:45
Hallo Lex,

ich glaube, diese Frage gehört zu den Top 5 der am häufigsten gefragten Fragen zu Excel! Lösungen hierzu im Netz NICHT zu finden erachte ich als unmöglich.

ich hoffe so ists jetzt genau erklärt.
Teste den Code und Du hast die Antwort auf diese Frage.
Option Explicit

Private Sub Worksheet_Change(ByVal Target As Range)
If Not Intersect(Target, Me.Range("A1")) Is Nothing Then
Application.EnableEvents = False
Me.Range("B1") = Date
End If
Application.EnableEvents = True
End Sub

Grüße
EarlFred

Lex8
04.07.2014, 18:17
GEnial,

super vielen Dank

lg gruß lex