PDA

Vollständige Version anzeigen : Sverweis mit wenn Funktion kombinieren


gabriel123
30.06.2014, 18:08
Hallo ich benötige eure Hilfe,

folgendes Problem: ich brauche eine Formel, die auf eine separate Excel Datei zugreift. Wenn die in der Sfunktion angegebenen Spalte (x) keinen Wert besitzt sollte sie auf die Spalte (y)zugreifen und deren Wert annehmen. Wenn diese nicht gefüllt ist dann 0.

Also eine Art Priorität setzten für Spalte x, sonst Spalte y. habe auch eine Testdatei angehangen. Tabelle 1 und Tabelle 2

Hoffe ihr könnt mir helfen,

Gruß G

Mc Santa
30.06.2014, 18:24
Hallo,

wenn immer nur in einer der beiden Spalten ein Wert steht (und niemals in beiden), dann kannst du es wie folgt lösen:
<table border="1" cellspacing="0" style="font-family:Calibri,Arial; font-size:11pt; background-color:#ffffff; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td >a</td><td style="text-align:right; ">100</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td >b</td><td style="text-align:right; ">200</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td >c</td><td style="text-align:right; ">200</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td >d</td><td style="text-align:right; ">100</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >B1</td><td >=SUMMENPRODUKT(<span style=' color:008000; '>N(Tabelle1!A1=Tabelle2!$A$1:$A$4)</span>;Tabelle2!$B$1:$B$4+Tabelle2!$C$1:$C$4)</td></tr><tr><td >B2</td><td >=SUMMENPRODUKT(<span style=' color:008000; '>N(Tabelle1!A2=Tabelle2!$A$1:$A$4)</span>;Tabelle2!$B$1:$B$4+Tabelle2!$C$1:$C$4)</td></tr><tr><td >B3</td><td >=SUMMENPRODUKT(<span style=' color:008000; '>N(Tabelle1!A3=Tabelle2!$A$1:$A$4)</span>;Tabelle2!$B$1:$B$4+Tabelle2!$C$1:$C$4)</td></tr><tr><td >B4</td><td >=SUMMENPRODUKT(<span style=' color:008000; '>N(Tabelle1!A4=Tabelle2!$A$1:$A$4)</span>;Tabelle2!$B$1:$B$4+Tabelle2!$C$1:$C$4)</td></tr></table></td></tr></table><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8 </a>

Hilft dir das weiter?
VG

gabriel123
30.06.2014, 18:30
Danke für den Tipp, leider ist das nicht der Fall, sondern manchmal gibt es in beiden Spalten einen Wert.
Vielleicht irgendwas in der Richtung:

=WENN(SVERWEIS(A1:A4;Tabelle2!A1:B4;2;FALSCH)<0;(SVERWEIS(A1:A4;Tabelle2!A1:B4;3;FALSCH)))

aber das Funktioniert auch nicht

Frank Furter
30.06.2014, 20:21
hallo, meinst du dann so..?

<table border='1' cellspacing='0' cellpadding='2' valign='middle' colspan='3' style='font-family:Calibri; color:#000000; background-color:#FFFFFF; font-size:11px; font-weight:normal; font-style:normal; '><colgroup><col width='28pt'><col width='60pt'><col width='60pt'></colgroup><tr style='background-color:#FAFAFA'><td align='middle' colspan='3'>Arbeitsblatt mit dem Namen 'Tabelle1'</td></tr><tr style='background-color:#cacaca'><td>*</td><td align='middle'>A</td><td align='middle'>B</td></tr><tr><td style='background-color:#cacaca' align='middle'>1</td><td align='left' >a</td><td align='right' >100</td></tr><tr><td style='background-color:#cacaca' align='middle'>2</td><td align='left' >b</td><td align='right' >200</td></tr><tr><td style='background-color:#cacaca' align='middle'>3</td><td align='left' >c</td><td align='right' >200</td></tr><tr><td style='background-color:#cacaca' align='middle'>4</td><td align='left' >d</td><td align='right' >100</td></tr></table><br><table border='3' cellspacing='0' cellpadding='2' valign='middle' colspan='2' style='table-layout:auto; color:#000000; background-color:#FFFFFF; font-family:Calibri; font-size:10px;'><colgroup><col width='40pt'><col></colgroup><tr style='background-color:#eeaaaa'><td>Zelle</td><td>Formel</td></tr><tr><td>B1</td><td><Span style='color:#222222'>=WENN</Span><Span style='color:#0000DD'>(SVERWEIS</Span><Span style='color:#222222'>(A1;Tabelle2!$A$1:$B$4;2;0)</Span><Span style='color:#0000DD'><Span style='color:#0000DD'><</Span>=0;SVERWEIS</Span><Span style='color:#222222'>(A1;Tabelle2!$A$1:$C$4;3;0)</Span><Span style='color:#0000DD'>;SVERWEIS</Span><Span style='color:#222222'>(A1;Tabelle2!$A$1:$B$4;2;0)</Span><Span style='color:#0000DD'>)</Span><Span style='color:#222222'></Span></td></tr></table><table style='font-family:Arial; font-size:7pt'><tr><td style='color:#333333'>Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg</td></tr></table>