PDA

Vollständige Version anzeigen : Kombinationsfeld bietet nicht den Inhalt aus der Ursprungstabelle an.


ercuem
17.02.2014, 20:06
Wie aus dem Titel erkennbar bietet das Kombifeld nicht den Inhalt aus der Ursprungstabelle an. Siehe Bild.

Woran kann das liegen?

http://s7.directupload.net/images/140217/8cblrv2p.png (http://www.directupload.net)

ebs17
17.02.2014, 22:01
Wieso? Die 5 Ziffern sind doch vorhanden.

Möglicherweise hat aber Dein Kombifeld eine zusätzlich wirkende Formatierung für den Steuerelementinhalt.

ercuem
17.02.2014, 22:09
Hallo

Danke für die Antwort

In der Tabelle sind die Werte in dieser Form gespeichert:

(0).XX.XX

maikek
17.02.2014, 22:21
Die sind dort vermutlich in dieser Form formatiert und werden daher so angezeigt.
Gespeichert sind sie wohl eher ohne die Zusatzzeichen, als reine Zahl.
Nimm halt eine Abfrage für das Kombi und formatiere das Feld in dieser Abfrage entsprechend.
maike

ebs17
17.02.2014, 22:24
Und was wunderst Du Dich da? Das Format aus der Tabelle wird offensichtlich an das gebundene Kombifeld durchgereicht.

Nebenbei muss man sich auch immer vergegenwärtigen, dass es zwischen dem real vorhandenen Wert und einer dargestellten Anzeige ein deutlicher Unterschied bestehen kann.

In praktischen Anwendungen verwendet man Formate regelmäßig erst dann, wenn sie wirklich benötigt werden, also nie in Tabellen, da diese nur zum Speichern von Daten dienen.

gpswanderer
17.02.2014, 22:27
Hallo,
In der Tabelle sind die Werte in dieser Form gespeichert:da irrst Du, dem Feld ist wahrscheinlich ein Eingabeformat zugewiesen das die fehlenden Zeichen nur vorgaugelt. Im Eingabeformat kann man in der 2. Rubrik wählen ob die Zeichen gespeichert werden sollen oder nicht.

Zeige mal das EingabeFormat.

ercuem
17.02.2014, 22:37
"("0")."09"."009""

So sehen die Zahlen in der Excel Tabelle aus.

(0) 3.4.139

und so auch

(0)1.1.34

aber ich seh schon das ich einen Fehler gemacht habe, aber das ändert nichts daran, das er mir die falsch anzeigt.

Die Kombis sind an eine Abfrage gebunden, die Abfrage ist nicht gespeichert. Das Eingabeformat ist beim Kombifeld gespeichert und nicht in der Tabelle.

Wie heißt denn die Option, das er die Zeichen mit speichern soll?

SELECT DISTINCT tbl_AuftrNr.NetwInterfVers FROM tbl_AuftrNr WHERE (((tbl_AuftrNr.NetwInterfVers) Is Not Null)) ORDER BY tbl_AuftrNr.NetwInterfVers;

gpswanderer
17.02.2014, 22:46
Hallo,
ob speichern oder nicht, muss im Eingabeformat in der 2.Abteilung angegeben werden. Das kannst Du in der Hilfe zum Eingabeformat nachlesen. Mit der Abfrage (SELECT ...) hat das nichts zu tun.