PDA

Vollständige Version anzeigen : Monat in Tage verteilen


schildi2000
02.08.2012, 11:48
Ich benötige bitte noch eine Hilfe:

in Zelle G3 schreibe ich MM.TTTT (z.B.: 08.2012)

jetzt möchte ich, dass in der Spalte A, ab A8, die Tage untereinander geschrieben werden (A8=01.08.2012, A9=02.08.2012, ... , A38=31.08.2012)

d.h. sobald ich einen anderen Monat wähle, dann bleibt A38 frei...

Danke im Voraus!

Uwe (:o)
02.08.2012, 11:55
Hallo,
diese Formel in A8 und runterkopieren sollte klappen:

=WENN(MONAT(DATUM(JAHR($G$3);MONAT($G$3);ZEILE(A1)))=MONAT($G$3);DATUM(JAHR($G$3 );MONAT($G$3);ZEILE(A1));"")

Wahrscheinlich geht es auch einfacher, aber darauf komme ich im Moment nicht.

schildi2000
02.08.2012, 12:08
Besten Dank!!!

GMG-CC
02.08.2012, 20:54
Hallo,

oder etwas anders: =WENN(MONAT($G$3+ZEILE()-8)=MONAT($G$3);$G$3+ZEILE()-8;"")
Natürlich steht in G3 1.8.2012, nur anders formatiert. (So habe ich es zumindest verstanden.)