PDA

Vollständige Version anzeigen : Werte an Zelle übergeben und damit weiterarbeiten


vbanewcomer
02.08.2012, 07:30
Guten Morgen Gemeinde,
ich bin gestern über ein Problem gestolpert was ich mir nicht erklären kann.

Mittels
Sheets("Einnahmen").Cells(lstrow, 1) = Format(Date, "dd.mm.yyyy")
Sheets("Einnahmen").Cells(lstrow, 1).Value = Label4


trage ich ein Datum in eine Tabelle ein

In einer weiteren Spalte kommt dann ein Betrag eingeschrieben.
Nun wird in meiner Tabelle in einem Feld alles zusammengerechnet was in einem bestimmten Monat aufgelaufen ist und dies somit in Abhängigkeit des Datums.

Wenn ich also nun mittels o.g. Code die Zelle beschreibe, so wird das Datum scheinbar nicht als solches erkannt da ich die Summe nicht in meiner Gesamtauswerrtung aufgerechnet bekomme.
Klicke ich aber nun in den Bearbeitungsbereich , ändere nichts und drücke lediglich Enter, so wird das Datum exakt übernommen und die Berechnung funktioniert ??

Kann mir jemand erklären wieso das so ist.

Die monatliche Berechnung funktioniert mit folgender Formel
=SUMME(WENN((ISTZAHL($A$8:$A$144))*($A$8:$A$144>=DATUM($A$149;$B163;1))*($A$8:$A$144<=DATUM($A$149;$B163+1;0))*ISTZAHL(E$8:E$144);E$8:E$144))

vielen Dankj für jeglichen Hinweis

Luschi
02.08.2012, 09:18
Hallo vbanewcomer,

versuch es mal so:

Sheets("Einnahmen").Cells(lstrow, 1).NumberFormat = "m/d/yyyy"
Sheets("Einnahmen").Cells(lstrow, 1).Value = Label4

Gruß von Luschi
aus klein-Paris

hoerzt
02.08.2012, 09:27
Hallo,

meine Vermutung: der Inhalt von Label4 ist Text. Also solltest du diesen etwa durch Multiplikation mit 1 in eine Zahl umwandeln.

LG hoerzt

vbanewcomer
02.08.2012, 12:27
@hoertz
Dachte ich auch schon aber wenn ich den Eintrag mittels Berechnung in eine Zahl umwandle entfällt das Datumformat ( auch wenn ich dieses im Anschluß mittels Code anpasse )

@ Luschi
Gleiche Problematik ( also keine Besserung )

Luschi
02.08.2012, 12:47
Hallo Hallo vbanewcomer,

dann mach es so:

Sheets("Einnahmen").Cells(lstrow, 1).NumberFormat = "m/d/yyyy"
Sheets("Einnahmen").Cells(lstrow, 1).Value = CDate(Label4)

Gruß von Luschi
aus klein-Paris

vbanewcomer
02.08.2012, 14:04
Das ist es. Super
vielen Dank