PDA

Vollständige Version anzeigen : Excel: Kalenderwoche mit Wenn-Bedingung


sillycat
31.07.2012, 12:43
Hallo Ihr Lieben

ich bräuchte Eure Hilfe bei folgendem Problem:

in Spalte A befinden sich Daten
in Spalte B soll die zugehörige Kalenderwoche angezeigt werden
befindet sich kein Datum in A, soll auch B leer bleiben

Folgende Formel für B: =WENN(A1>0;KALENDERWOCHE(A1;21);"")

Das funktioniert für Zellen mit Datum sehr gut.
Trotzdem habe ich für eine leere Zelle in A ein #Wert! in B stehen.

Ich vermute, dass es damit zusammenhängt, dass auch für die (leeren) Zellen in A eine Fomel hinterlegt ist: =WENN(Tabelle1!A1>0;Tabelle1!A1;"")

Gibt es eine Möglichkeit dieses Problem zu lösen, oder ist die Formel doch fehlerhaft?

Herzlichen Dank und liebe Grüsse

Yvonne

JD124578963
31.07.2012, 12:53
Hallo Yvonne;

ich würde das folgendermaßen probieren

=wenn(und(A1>0;A1<>"");kalenderwoche(A1,21);"")

Habs jetzt aber noch nicht getestet.:)



Mit freundlichen Grüßen

JD

sillycat
31.07.2012, 13:24
Oooooooohh
toll, toll, toll das geht!

Vielen Dank für die superschnelle hilfreiche Antwort!!

vbanewcomer
01.08.2012, 08:02
müsste das nicht eine oder Funktion werden oder habe ich das Problem nicht richtig verstanden ( auch wenn bereits gelöst )

=wenn(oder(A1>0;A1<>"");kalenderwoche(A1,21);"")