PDA

Vollständige Version anzeigen : Abfrage per Vergleich ?


dapaco
19.07.2012, 14:02
Hallo,
ich frage mit folgender Formel Postleitzahlen in einem anderen Tabellenblatt ab

=WENN(ISTFEHLER(SVERWEIS($A$2;Daten!A:F;2;FALSCH));"3";(SVERWEIS($A$2;Daten!A:F;2;FALSCH)))

Falls die Formel eine PLZ findet wird in einer Zelle ein Wert eingetragen. entweder eine 1 oder eine 2

Falls in "A2" nichts steht, oder die plz per Abfrage nicht gefunden wurde steht eine 3 drinnen.

Ich möchte jetzt aber, dass wenn in "a2" nichts steht, auch keine 3 in der zelle steht in welcher sich die Formel befindet.
Dh. nur wenn die PLZ nicht gefunden wurde soll eine 3 in der Zelle stehen.

Müsste ich das mit nem Vergleich lösen? Hat vllt jemand einen Lösungsvorschlag?

Grüße, Thomas

mücke
19.07.2012, 14:10
Moin Thomas,

meinst Du so:
=WENN(A2="";"";WENN(ISTFEHLER(SVERWEIS($A$2;Daten!A:F;2;FALSCH));"3";(SVERWEIS($A$2;Daten!A:F;2;FALSCH))))

EarlFred
19.07.2012, 14:12
Hallo Thomas,

mal als Ansatz:
=WENN(
ISTLEER($A$2);
"";
WENN(
ZÄHLENWENN(Daten!A:A;$A$2);
SVERWEIS($A$2;Daten!A:F;2;0);
3
)
)
(Formel kann so formatiert eingegeben werden - mir erleichtert das die Lesbarkeit)

Zahlenwerte stehen übrigens nicht in Anführungszeichen.

Grüße
EarlFred

dapaco
19.07.2012, 14:13
hammer !! :) vielen DANK !!!