PDA

Vollständige Version anzeigen : Hyperlink durch Sverweis


dapaco
19.07.2012, 10:01
Hallo,
Ich hole mir per Sverweis Daten in ein anderes Tabellenblatt.
Im Tabellenblatt 1 habe ich in einer Zelle einen Hyperlink hinterlegt ( eine emailadresse)
Wenn ich mir nun in dem Tabellenblatt 2 die Zelle per sverweis hole möchte ich per klick auf diese ( hinterlegt ist der name und nachname ) den hyperlink ausführen.
habs schon so probiert

=HYPERLINK(SVERWEIS(A2;Daten!Q:S;3;FALSCH))

kommt aber folgender Fehler
Die angegebene Datei konnte nicht geöffnet werden !

Hat jemand eine Idee ?

Grüße, Thomas

chris-kaiser
19.07.2012, 10:28
Hi


=HYPERLINK("Mailto:"&SVERWEIS(A2;Daten!Q:S;3;0);SVERWEIS(A2;Daten!Q:S;3;0))

mal ein Versuch

dapaco
19.07.2012, 10:37
hi chris,
jetzt habe ich in der zelle ein "Wahr" stehen. (blau hinterlegt)
kann diese aber nicht anklicken.
eigentlich sollte ja die zelle drinnen stehen die ich per sverweis hergeholt habe

chris-kaiser
19.07.2012, 10:39
Hi

dann passt der Sverweis nicht ;)

dapaco
19.07.2012, 12:18
jetzt hats funktioniert. vielen Dank !

dapaco
19.07.2012, 12:24
vllt noch eine frage. wie könnte ich die funktion istfehler einbauen, sodass #nv nicht angezeigt wird? Grüße

mücke
19.07.2012, 12:37
Moin Thomas,

dafür würde ich Wennfehler(...) benutzen, schau mal hier:
<b>Tabelle1</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Calibri,Arial; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:80px;" /><col style="width:80px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >F</td><td >G</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >16</td><td style="text-align:right; ">123</td><td style="color:#0000ff; text-decoration:underline; ">m.Muster@xyz.at</td></tr><tr style="height:18px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >17</td><td style="text-align:right; ">22</td><td style="color:#0000ff; ">&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >G16</td><td >=WENNFEHLER(HYPERLINK<span style=' color:008000; '>("Mailto:"&SVERWEIS<span style=' color:#0000ff; '>(F16;B:C;2;0)</span>;SVERWEIS<span style=' color:#0000ff; '>(F16;B:C;2;0)</span>)</span>;"")</td></tr><tr><td >G17</td><td >=WENNFEHLER(HYPERLINK<span style=' color:008000; '>("Mailto:"&SVERWEIS<span style=' color:#0000ff; '>(F17;B:C;2;0)</span>;SVERWEIS<span style=' color:#0000ff; '>(F17;B:C;2;0)</span>)</span>;"")</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

dapaco
19.07.2012, 12:42
jawoll funktioniert. vielen Dank !