PDA

Vollständige Version anzeigen : Zuständigkeit nach Postleitzahlen


dapaco
18.07.2012, 14:12
Hallo,
Anhand einer Postleitzahl, welche ich in einem Tabellenblatt eingebe, hole ich mir per Sverweis einige Daten.
Jetzt möchte ich wissen, welche Person in welchen Gebiet zuständig ist.
Dh. Ich gebe in Tabellenblatt die PLZ ein und er soll mir in einer Zelle den Namen ausspucken. müsste ja mit Sverweis funktionieren.

Habe allerdings nur folgende eingaben in einer Tabell als Grundlage auf die ich zugreifen möchte

Plz von PLZ bis Name
34290 34339 Geiger
34340 34349 Schneider
34350 34358 Geiger
34359 34529 Scheider
34530 34999 Geiger
...usw

Müsste ich mir da ne ewig lange sverweis formel basteln?

Grüße, Thomas

EarlFred
18.07.2012, 14:19
Hallo Thomas,

Müsste ich mir da ne ewig lange sverweis formel basteln?
"lang" ist relativ...
Wenn in E2 die gesuchte PLZ stünde:
=SVERWEIS(E2;A2:C6;3;1)

Wenn noch eine Abfrage dazu soll, wenn die gesuchte PLZ größer als größte zugeordnete ist:
=WENN(E2>MAX(B2:B6);"nicht festgelegt!";SVERWEIS(E2;A2:C6;3;1))

Funktioniert freilich nur, wenn die PLZ wie im Beispiel lückenlos zugeordnet und sortiert sind. Siehe OH zum Sverweis.

Grüße
EarlFred

Pit987
18.07.2012, 14:25
Hallo!
Für den Geiger hast Du die PLZ 34290 34339
A1 34290
A2 A1+1
....
A50 A49+1
So kommst Du auf 50 Zeilen für den ersten Bereich.
Es werden nicht alle PLZ existieren, aber Du erhälst eine einfache Zuordnung von der Zahl zum Namen.
Das hält die Formel einfach und überschaubar.

Viel Erfolg
Pit

dapaco
18.07.2012, 15:43
Vielen Dank euch beiden.
Bin gerade dabei die Lösung von Pit auszuführen.
Scheint gut zu laufen. Ist aber ganz schön aufwendig. Aber Hauptsache es funktioniert. THX

Uwe (:o)
18.07.2012, 16:20
Hallo Pit,
schau mal, ob Du damit klar kommst.
Ich bevorzuge INDEX / VERGLEICH gegenüber SVERWEIS:
<b>Tabelle3</b><br /><br /><table border="1" cellspacing="0" cellpadding="0" style="font-family:Tahoma,Arial; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:89px;" /><col style="width:89px;" /><col style="width:118px;" /><col style="width:7px;" /><col style="width:119px;" /><col style="width:88px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td><td >E</td><td >F</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td style="font-size:14pt; ">Plz von</td><td style="font-size:14pt; ">PLZ bis</td><td style="font-size:14pt; ">Name</td><td >&nbsp;</td><td style="color:#ff0000; font-size:14pt; ">Gesucht: &nbsp;</td><td style="color:#ff0000; font-size:14pt; ">Name: </td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td style="font-size:14pt; text-align:right; ">34290</td><td style="font-size:14pt; text-align:right; ">34339</td><td style="font-size:14pt; ">Geiger</td><td >&nbsp;</td><td style="color:#ff0000; font-size:14pt; text-align:right; ">35012</td><td style="color:#ff0000; font-size:14pt; ">Geiger</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td style="font-size:14pt; text-align:right; ">34340</td><td style="font-size:14pt; text-align:right; ">34349</td><td style="font-size:14pt; ">Schneider</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td style="font-size:14pt; text-align:right; ">34350</td><td style="font-size:14pt; text-align:right; ">34358</td><td style="font-size:14pt; ">Geiger</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td style="font-size:14pt; text-align:right; ">34359</td><td style="font-size:14pt; text-align:right; ">34529</td><td style="font-size:14pt; ">Scheider</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr><tr style="height:22px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >6</td><td style="font-size:14pt; text-align:right; ">34530</td><td style="font-size:14pt; text-align:right; ">34999</td><td style="font-size:14pt; ">Geiger</td><td >&nbsp;</td><td >&nbsp;</td><td >&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >F2</td><td >=INDEX(C2:C10;VERGLEICH<span style=' color:008000; '>(E2;A2:A10;1)</span>)</td></tr></table></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

EarlFred
18.07.2012, 16:55
Hallo Uwe,

Ich bevorzuge INDEX / VERGLEICH gegenüber SVERWEIS
ist das nur eine Frage des Geschmacks oder hat es noch andere Gründe (außer, dass es flexibler ist, vor allem in Bezug auf die Lage der Suchspalte)?
Ansonsten gelten ja die Bedingungen / Einschränkungen analog zum SVerweis.

Grüße
EarlFred

Uwe (:o)
18.07.2012, 17:24
Hallo EarlFred,
ich bevorzuge es einfach, weil es - wie Du schon schreibst - flexibler ist.
Nicht nur wg. der Suchspalte (SVERWEIS nach links) sondern auch, weil ich damit z.B. in einer Kreuztabelle beide Parameter suchen kann.
Außerdem finde ich es auch übersichtlicher, weil ich nicht erst Spalten zählen muss (3tes Argument), sondern direkt sehe, welche Spalte ich ausgebe.
Ich habe auch schon von anderen Leuten gehört, dass sie SVERWEIS aus ihrem "Repertoire" gestrichen haben.
Aber natürlich ist es zudem auch ein bisschen Geschmackssache.