PDA

Vollständige Version anzeigen : Textvergleich mit Zuweisung


maxias
18.07.2012, 07:58
Guten Tag

Ich möchte ein Feld mit einer Spalte vergleichen (übereinstimmendes Feld finden). dann das Feld, zwei Spalten weiter auf Zeilenhöhe des Fundfeldes, als Rückgabe in ein Feld übergeben.

Ich habe zwei Excel-Sheets mit Dateinamen. Leider sind sie nicht in der selben Reihenfolge und der Name stimmt nur in den ersten 9 Zeichen überein.

http://s12.postimage.org/83haawdjv/image.png

Vergleich B1 mit Zeile A (sheet quelle_intranet)

http://s15.postimage.org/ubplajfyx/image.png

ein Vergleich der ersten zeichen habe ich hier bereits versucht:
=WENN(ISTZAHL(FINDEN(LINKS(B1;8);LINKS(quelle_intranet!A:A;8)));"ok";"nicht ok")

und ein SVERWEIS ebenfalls:
=SVERWEIS(B1;quelle_intranet!A:A;1;FALSCH)

Nun muss man das ganze noch in eine WENN abfrage kombinieren, was mir nicht glingt.

können sie mir bitte weiterhelfen

Cheers

IngGi
18.07.2012, 08:13
Hallo maxias,

so?

<table border="1" cellspacing="0" cellpadding="0" style="font-family:Arial,Arial; font-size:11pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; " /><col style="width:88px;" /><col style="width:88px;" /><col style="width:88px;" /><col style="width:88px;" /></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td >&nbsp;</td><td >A</td><td >B</td><td >C</td><td >D</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >1</td><td >eins</td><td >vim</td><td >sechs </td><td >neun</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >2</td><td >zwei</td><td >&nbsp;</td><td >sieben</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >3</td><td >drei</td><td >&nbsp;</td><td >acht</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >4</td><td >vier</td><td >&nbsp;</td><td >neun</td><td >&nbsp;</td></tr><tr style="height:17px ;" ><td style="font-size:8pt; background-color:#cacaca; text-align:center; " >5</td><td >f&uuml;nf</td><td >&nbsp;</td><td >zehn</td><td >&nbsp;</td></tr></table><br /><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td ><b>Formeln der Tabelle</b></td></tr><tr><td ><table border = "1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td >Zelle</td><td >Formel</td></tr><tr><td >D1</td><td >{=INDEX($C$1:$C$5;VERGLEICH(LINKS(B1;2);LINKS($A$1:$A$5;2);0))}</td></tr></table></td></tr><tr><td ><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>Enth&auml;lt Matrixformel:</span><span style=' font-family:Arial,Arial; font-size:9pt;'><br />Umrandende </span><span style=' font-family:Arial,Arial; font-size:9pt; font-weight:bold;'>{ }</span><span style=' font-family:Arial,Arial; font-size:9pt;'> nicht miteingeben,<br />sondern Formel mit STRG+SHIFT+RETURN abschlie&szlig;en!</span></td></tr><tr><td ><a href="http://www.online-excel.de/excel/singsel.php?f=26" style="font-family:Arial; font-size:8pt;font-weight:bold;color:#000080;" target='_blank'>Matrix verstehen</a></td></tr></table> <br /><br /><span style="font-family:Arial; font-size:9pt; font-weight:bold;background-color:#ffffff; color:#000000; ">Excel Tabellen im Web darstellen &gt;&gt; </span><a style ="font-family:Arial; font-size:9pt; color:#fcf507; background-color:#800040; font-weight:bold;" href="http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4 </a>

Gruß Ingolf

maxias
18.07.2012, 10:18
perfekt. hat geklappt

tausenddank