PDA

Vollständige Version anzeigen : Mittelwert der Differenzen


Solander
13.07.2012, 21:06
Hallo,

für die Auswertung eines Tests muss ich den Mittelwert aller möglichen (absoluten) Differenzen der Testpersonen ermitteln. Da das ja ziemlich schnell ziemlich viele werden, würde ich das gerne über eine Formel lösen. Nach etwas suchen habe ich Ginis mittlere Differernz (http://www.excel4managers.de/index.php?page=gmd) gefunden, weiß aber nicht ob die genau das aussagt, was ich brauche (Formelverständnisgedächtnis ist etwas eingerostet...)
Zum testen habe ich händisch die absoluten Differenzen berechnet und dann geteilt und zusätzlich die angegebene Formel verwendet, komme aber auf andere Ergebnisse (siehe Anhang Tabelle "Familia").
Hat jemand eine Ahnung wie ich das besser lösen könnte (ohne 50 Vergleiche einzutippen...?).

Vielen Dank schonmal für Ideen!

Uwe (:o)
13.07.2012, 21:43
Hallo,
teste mal diese Formel für die gesamte Matrix, also von B2-C2 bis K2-L2 in z.B. Zelle T2 (und runterkopieren):

=SUMMENPRODUKT(ABS(B2:K2-C2:L2))/ANZAHL(B2:K2)

Entspricht das Deinen Vorstellungen?

Solander
13.07.2012, 23:04
Hallo Uwe,

vielen Dank schonmal! Nachdem ich mein Matrixwissen erweitert habe, kann ich dir antworten, dass es in die richtige Richtung geht, aber noch nicht ausreicht.
Deine Formel berechnet ja im Grunde die Differenz einer Zelle mit ihrer rechten Nachbarzelle (und mittelt und so). Ich brauche aber die Differenz aller Zellen einer zeile zueinannder (also insgesamt n*(n-1)/2 Differenzen).
Ich würde mich über weitere Ideen sehr freuen!

Solander
14.07.2012, 03:33
Ich habe jetzt keine Bearbeitenfunktion gefunden, aber dafür glaube ich die Lösung. Nachdem ich mir nochmal ein wenig die Formel der mittleren Gini Differenz angesehen habe (1 (http://www.xycoon.com/gini_mean_difference.htm), 2 (http://en.wikipedia.org/wiki/Mean_difference#Calculation)) und mit der eingangs verlinkten Formel verglichen habe, ist mir aufgefallen, dass ebenfalls die Differenz der Zahlen mit sich selbst berechnet wurden. Diese meiner Meinung nach in der ursprünglichen Formel nichtvorhandenen Vergleiche führen zum Problem. Wenn ich also statt durch n^2 durch n^2-n teile, bekomme ich das Ergebnis, das ich auch von Hand ausgerechnet habe :)

Gesamte Formel:
=SUMME(ABS(B2:L2-MTRANS(B2:L2)))/((ANZAHL(B2:L2)^2)-ANZAHL(B2:L2))

Vielleicht könnte eine Person mit mehr Matheverständnis als ich nochmal was dazu sagen.

hoerzt
14.07.2012, 10:53
Hallo,

teste doch mal folgndes wenn deine Werte in A1:A4 stehen:

Formel in B1: =SUMMENPRODUKT(ABS($A$1:$A$4-A1))/(ANZAHL2($A$1:$A$4)-1)

Ergebnisformel: =SUMME(B1:B4)/ANZAHL2(A1:A4)

LG hoerzt

Solander
25.07.2012, 16:15
Vielen Dank, das klappt!
Jetzt habe ich ein neues Problem. Nachdem ich nicht immer alle Daten (Kinder) habe, sollen nur die Personen (Spalten) berücksichtigt werden, bei denen nicht alle Werte null sind. Kann ich das irgendwie überprüfen?

Vielen Dank!

hoerzt
25.07.2012, 16:45
Hallo Solander,

da ich deine Aufgabenstellung leider nicht verstehe, kann ich dir auch nicht weiterhelfen :-(((

Bitte versuche deine Frage etwas verständlicher zu stellen.

LG hoerzt

Solander
25.07.2012, 19:52
Ah sorry, da war ich in der Eile wohl zu ungenau!

Hab mal ein Beispiel erstellt. Ich habe für x Personen (Werte) die Ergebnisse von 10 Skalen. Jetzt will ich für jede Skala den Mittelwert und die gemittelte Differenz ermitteln. Wenn ich von allen 10 Personen die Ergebnisse habe, kein Problem. Jetzt passiert es aber, wie in dem Beispiel, dass ich z.B. von den letzten drei Personen keine Ergebnisse habe (auf allen Skalen 0 ist). Diese Personen sollen nun natürlich ausgeschlossen werden, da sonst die Mittelwerte verfälscht würden.
Problem: Das Ergebnis einer Skala kann null sein, es darf aber nur ausgeschlossen werden, wenn die Summe aller Skalenwerte null ist.

Ich hoffe es ist verständlicher und Bedanke mich bereits für die Mühen!

hoerzt
26.07.2012, 12:11
Hallo,

sieh dir mal den Anhang an, ob dir damit geholfen ist. Meine Änderungen und Ergänzungen erkennst du an der farblichen Hinterlegung der Zellen.

LG hoerzt

Solander
26.07.2012, 13:46
Wow, krass! Vielen Dank, werde versuchen es zu verstehen, funktionieren tut es schonmal :)