PDA

Vollständige Version anzeigen : Objektnahme Autokorrektur


Franz Karl
20.06.2012, 13:06
Hallo zusammen,

ich habe diese Funktion benutzt hat soweit auch funktioniert. D.h.

- Abfragen wurden auf umbenannte Tabellen umgestellt


Danach habe ich die geänderten Abfragen wieder in eine Datenbank übernommen bei der diese Option ausgeschalten ist (soll auf Lasten der Performance gehen).


Dabei sind Abfragen die umgestellt wurden wieder mit Ihren ursprünglichen Tabellen übernommen worden - woran kann das liegen ?

Gruss
FK

Marsu65
20.06.2012, 14:50
Hallo Franz,
Danach habe ich die geänderten Abfragen wieder in eine Datenbank übernommen bei der diese Option ausgeschalten ist ...
Kannst du beschreiben wie du die Abfragen übernommen hast?
Hast du Sie in eine neue/andere DB importiert?

Ich würde das gerne mal nachstellen.

Franz Karl
20.06.2012, 14:54
Hallo Marsu,

ich habe sie in der neuen MDB-Datei (dort von Anfang an diese Option ausgeschalten) aus der alten importiert. Mit Option alle auswählen !

Habe das Gefühl man muss sie vorher speichern ? Aber ich kann eben nicht über 500 Abfragen einzeln öffenen und speichern.
Gruss
Franz

Thomas Möller
20.06.2012, 19:13
Hallo Franz,

Aber ich kann eben nicht über 500 Abfragen einzeln öffenen und speichern.

einen solchen Job könntest Du doch per VBA erledigen lassen - oder? ;)

CU

Franz Karl
22.06.2012, 14:10
Hallo,

stimmt, aber dieses Tool arbeitet nicht so korrekt zumindest bei meinem Stand hier --> manche Abfragen wurden überhaupt nicht angepasst obwohl ich die Quell-Tabelle umbenannt habe.

ebs17
22.06.2012, 14:34
aber dieses Tool arbeitet nicht so korrekt
Auch MS-Assistenten sind nur Hilfsmittel (deren Grenzen man auch kennen sollte) und nicht Rundum-Sorglos-Pakete.

1. Empfehlung: Verwende Find&Replace (http://www.rickworld.com/) von Rick Fisher, das ist durchschlagend.

2. Empfehlung: Eine gute Vorplanung verhindert nachträgliche massive Änderungen. Die Objektnamen-Autokorrektur ist nun mal eine Anfängerhilfe. Als Fortgeschrittener wird man auf diese Hilfe durchgehend verzichten, schon weil sie eine enorme Performancebremse ist.